Opened 5 years ago

Closed 5 years ago

#53454 closed defect (duplicate)

Error Building nodejs4 on OS X 10.11.6

Reported by: dbl001 (dbl) Owned by: ci42
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: nodejs4

Description (last modified by ryandesign (Ryan Schmidt))

$ sudo port clean nodejs4; sudo port install nodejs4
--->  Cleaning nodejs4
--->  Computing dependencies for nodejs4
--->  Fetching archive for nodejs4
--->  Attempting to fetch nodejs4-4.7.2_0.darwin_15.x86_64.tbz2 from https://packages.macports.org/nodejs4
--->  Attempting to fetch nodejs4-4.7.2_0.darwin_15.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/nodejs4
--->  Attempting to fetch nodejs4-4.7.2_0.darwin_15.x86_64.tbz2 from http://kmq.jp.packages.macports.org/nodejs4
--->  Fetching distfiles for nodejs4
--->  Verifying checksums for nodejs4
--->  Extracting nodejs4
--->  Applying patches to nodejs4
--->  Configuring nodejs4
--->  Building nodejs4
Error: Failed to build nodejs4: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port nodejs4 failed
$ 5ail opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/main.log 
:info:build   /usr/bin/clang++ '-D_DARWIN_USE_64_BIT_INODE=1' '-DGTEST_DONT_DEFINE_ASSERT_EQ=1' '-DGTEST_DONT_DEFINE_ASSERT_GE=1' '-DGTEST_DONT_DEFINE_ASSERT_GT=1' '-DGTEST_DONT_DEFINE_ASSERT_LE=1' '-DGTEST_DONT_DEFINE_ASSERT_LT=1' '-DGTEST_DONT_DEFINE_ASSERT_NE=1' -I../deps/gtest/include -I../deps/v8/include -I../src -I/opt/local/include -I/opt/local/include/openssl  -Os -gdwarf-2 -arch x86_64 -Wall -Wendif-labels -W -Wno-unused-parameter -std=gnu++0x -fno-rtti -fno-exceptions -fno-threadsafe-statics -fno-strict-aliasing -MMD -MF /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/work/node-v4.7.2/out/Release/.deps//opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/work/node-v4.7.2/out/Release/obj.target/cctest/test/cctest/util.o.d.raw  -Os -stdlib=libc++ -c -o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/work/node-v4.7.2/out/Release/obj.target/cctest/test/cctest/util.o ../test/cctest/util.cc
:info:build In file included from ../test/cctest/util.cc:1:
:info:build ../src/util.h:27:53: error: no member named 'tr1' in namespace 'std'
:info:build template <typename T> using remove_reference = std::tr1::remove_reference<T>;
:info:build                                                ~~~~~^
:info:build ../src/util.h:27:74: error: expected ';' after alias declaration
:info:build template <typename T> using remove_reference = std::tr1::remove_reference<T>;
:info:build                                                                          ^
:info:build                                                                          ;
:info:build 2 errors generated.
:info:build make[1]: *** [/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/work/node-v4.7.2/out/Release/obj.target/cctest/test/cctest/util.o] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/work/node-v4.7.2/out'
:info:build make: *** [node] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/work/node-v4.7.2'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs4/nodejs4/work/node-v4.7.2" && /usr/bin/make -w all CC=/usr/bin/clang CXX=/usr/bin/clang++ CXX.host=/usr/bin/clang++ CPP=/usr/bin/cpp CFLAGS="-Os" CXXFLAGS="-Os -stdlib=libc++" LDFLAGS="-L/opt/local/lib -Wl,-headerpad_max_install_names" PYTHON=/opt/local/bin/python2.7 V=1
:info:build Exit code: 2
:error:build Failed to build nodejs4: command execution failed
:debug:build Error code: CHILDSTATUS 45393 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"

Attachments (1)

main.log (734.8 KB) - added by dbl001 (dbl) 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by dbl001 (dbl)

Attachment: main.log added

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: nodejs4 removed
Owner: set to ci42
Port: nodejs4 added
Status: newassigned

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #53401.

Note: See TracTickets for help on using tickets.