Opened 15 years ago

Closed 15 years ago

#5369 closed defect (wontfix)

BUG: Ethereal dependencies list incomplete

Reported by: jnetto@… Owned by: opendarwin.org@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: toby@…
Port:

Description

I tried to build ethereal 0.10.12_2+darwin_7 and it couldn't because it fails to find pkgconfig installed. I already had gtk2 and glib installed. So i went installing pkgconfig and the build process ran ok. But looking in the list of dependencies of ethereal, there's nothing telling that you have to have pkgconfig installed, and consequently, the build will fail:

pirama:~ jnetto$ port deps ethereal ethereal has library dependencies on:

glib2 gtk2 openssl libpcap zlib

Is it ok? I run a DarwinPorts version 1.102.

Attachments (1)

py-libpcap.patch (927 bytes) - added by chris.owen@… 15 years ago.
Here's the patch

Download all attachments as: .zip

Change History (6)

comment:1 Changed 15 years ago by opendarwin.org@…

Status: newassigned
Summary: Ethereal dependencies list incomplete Ethereal dependencies list incomplete

comment:2 Changed 15 years ago by mww@…

Cc: toby@… added
Owner: changed from darwinports-bugs@… to opendarwin.org@…
Status: assignednew
Summary: Ethereal dependencies list incompleteBUG: Ethereal dependencies list incomplete

comment:3 Changed 15 years ago by opendarwin.org@…

Status: newassigned

Changed 15 years ago by chris.owen@…

Attachment: py-libpcap.patch added

Here's the patch

comment:4 Changed 15 years ago by chris.owen@…

attachments.isobsolete: 01

comment:5 Changed 15 years ago by toby@…

Resolution: wontfix
Status: assignedclosed

glib2 depends on pkgconfig

Note: See TracTickets for help on using tickets.