Opened 15 years ago

Closed 15 years ago

#5372 closed defect (duplicate)

BUG: Upgrade try to activate old openssl

Reported by: jnetto@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

Today i ran 'port -a upgrade' and got an error after upgrading openssl...

Though the process runs smoothly and the new version gets activated:

---> Fetching openssl ---> Attempting to fetch openssl-0.9.8a.tar.gz from http://www.openssl.org/source/ ---> Verifying checksum(s) for openssl ---> Extracting openssl ---> Applying patches to openssl ---> Configuring openssl ---> Building openssl with target all ---> Staging openssl into destroot ---> Deactivating openssl 0.9.8_0 ---> Packaging tgz archive for openssl 0.9.8a_0 ---> Installing openssl 0.9.8a_0 ---> Activating openssl 0.9.8a_0 ---> Cleaning openssl

The upgrade process try to activade the old version. This output occurs...

---> Activating openssl 0.9.8_0 Error: Activating openssl 0.9.8_0 failed: Image error: Another version of openssl (0.9.8a_0) is already active.

This message gets printed till the process is complete. Everything then is ok and running, but getting this error message could be annoying...

I'm running DarwinPorts version 1.102, under MacOS X 10.3.9.

Change History (2)

comment:1 Changed 15 years ago by mww@…

Summary: Upgrade try to activate old opensslBUG: Upgrade try to activate old openssl

comment:2 Changed 15 years ago by blb@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 5497 *

Note: See TracTickets for help on using tickets.