Opened 4 years ago

Closed 3 years ago

#53946 closed request (fixed)

req: Tensorflow

Reported by: kencu (Ken) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: Schamschula (Marius Schamschula), petrrr, vamsi765
Port:

Description

This seems like a useful tool. I saw this used to good effect in a couple of projects doing image recognition at a major science fair today.

<https://www.tensorflow.org/install/install_sources>

Looks like something for someone skilled in python ports to consider -- and that's not my area.

Change History (16)

comment:1 Changed 4 years ago by kencu (Ken)

argh. this is a port request, not a defect. sorry, can't change it.

comment:2 Changed 4 years ago by Schamschula (Marius Schamschula)

Type: defectrequest

comment:3 Changed 4 years ago by Schamschula (Marius Schamschula)

Cc: Schamschula added

comment:4 Changed 4 years ago by Schamschula (Marius Schamschula)

I've built all the prerequisites for Tensorflow, but I haven't been able to figure out how to get bazel to actually build Tensorflow...

Last edited 4 years ago by Schamschula (Marius Schamschula) (previous) (diff)

comment:6 Changed 3 years ago by petrrr

Cc: petrrr added

comment:7 Changed 3 years ago by vamsi765

Is somebody looking at this request?

comment:8 Changed 3 years ago by vamsi765

Cc: vamsi765 added

comment:9 Changed 3 years ago by kencu (Ken)

I have what appears to be a working file to build libtensorflow-devel. I only built it on highsierra -- all other systems are presently untested.

<https://github.com/kencu/myports/tree/master/devel/libtensorflow-devel>

Requires (I think) the new build of bazel to build. I used bazel 0.9.0, which is not in MacPorts yet. <https://github.com/kencu/myports/tree/master/devel/bazel>

The build proceeds apace, but then there is a hellish long pause where nothing seems to happen (like 2 hours on my 8 core MacPro). Then -- it's done. If anyone knows what is going on during this pause, feel free to volunteer some advice.

Assuming this passes criticism, I'll commit it once bazel 0.9.0 is in MacPorts.

Last edited 3 years ago by kencu (Ken) (previous) (diff)

comment:10 Changed 3 years ago by mf2k (Frank Schima)

See #55407 for the bazel update.

comment:11 Changed 3 years ago by vamsi765

Hi,

Now that Bazel 0.9.0 is in, would this also be added to MacPort?

Thanks Vamsi

comment:12 Changed 3 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

comment:13 Changed 3 years ago by vamsi765

Hi,

There doesn't seem to be a dependency port.

> sudo port install py36-tensorflow-tensorboard
Password:
--->  Computing dependencies for py36-tensorflow-tensorboard
Error: Dependency 'py36-protobuf3' not found.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port py36-tensorflow-tensorboard failed


> sudo port install py36-tensorflow
--->  Computing dependencies for py36-tensorflow
Error: Dependency 'py36-protobuf3' not found.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port py36-tensorflow failed

> sudo port install py36-protobuf3
Error: Port py36-protobuf3 not found

comment:14 Changed 3 years ago by vamsi765

Resolution: fixed
Status: closedreopened

comment:15 Changed 3 years ago by kencu (Ken)

these issues are being tracked in another ticket 55972

comment:16 Changed 3 years ago by kencu (Ken)

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.