Opened 6 years ago

Closed 3 years ago

#53980 closed update (wontfix)

caffe: update to rc5

Reported by: JacksonIsaac (Jackson Isaac) Owned by: JacksonIsaac (Jackson Isaac)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: caffe

Description

Latest released version of caffe is rc5 and the one provided through MacPorts is few years old already.

I have already updated the Portfile and updated the patch files accordingly. I am facing some error related to opencv. Probably because opencv is by default built against python 3.x and caffe is trying to build it against python 2.7

Attaching the patch and error log with the ticket.

I would be happy to try to update the port.

Attachments (2)

caffe_opencv_error.log (8.8 KB) - added by JacksonIsaac (Jackson Isaac) 6 years ago.
caffe_rc5_update.patch (9.8 KB) - added by JacksonIsaac (Jackson Isaac) 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by JacksonIsaac (Jackson Isaac)

Attachment: caffe_opencv_error.log added

Changed 6 years ago by JacksonIsaac (Jackson Isaac)

Attachment: caffe_rc5_update.patch added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Cc: JacksonIsaac removed
Keywords: haspatch added

Can you update your patches for version 1.0?

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Actually the port is currently at a newer GitHub tag than 1.0.

comment:3 Changed 3 years ago by JacksonIsaac (Jackson Isaac)

Resolution: wontfix
Status: newclosed

Closing this ticket due to inactivity.

Feel free to reopen if there is any update.

Note: See TracTickets for help on using tickets.