Opened 15 years ago

Closed 15 years ago

#5403 closed defect (worksforme)

BUG: 1.102 webalizer installation fails: ld: Undefined symbols: libiconv

Reported by: amgine@… Owned by: mike.mclean@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: amgine@…
Port:

Description

libiconv is installed via port:

The following ports are currently installed:

... libiconv 1.10_1+darwin_7 (active)

webalizer debug output:

Saewyc-Desktop:~ amgine$ sudo port -d install webalizer DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/www/webalizer DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/www/webalizer DEBUG: Requested variant powerpc is not provided by port webalizer. DEBUG: Requested variant darwin is not provided by port webalizer. DEBUG: Requested variant macosx is not provided by port webalizer. DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/graphics/gd2 DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/graphics/gd2 DEBUG: Searching for dependency: gd2 DEBUG: Found Dependency: receipt exists for gd2 DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/archivers/zlib DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/archivers/zlib DEBUG: Searching for dependency: zlib DEBUG: Found Dependency: receipt exists for zlib DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/graphics/libpng DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/graphics/libpng DEBUG: Searching for dependency: libpng DEBUG: Found Dependency: receipt exists for libpng DEBUG: Skipping completed com.apple.main (webalizer) DEBUG: Skipping completed com.apple.unarchive (webalizer) DEBUG: Skipping completed com.apple.fetch (webalizer) DEBUG: Skipping completed com.apple.checksum (webalizer) DEBUG: Skipping completed com.apple.extract (webalizer) DEBUG: Skipping completed com.apple.patch (webalizer) DEBUG: Skipping completed com.apple.configure (webalizer) ---> Building webalizer with target all DEBUG: Executing com.apple.build (webalizer) DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_www_webalizer/work/webalizer-2.01-10" && make all' gcc -L/opt/local/lib -L/opt/local/lib -L/opt/local/lib -o webalizer webalizer.o hashtab.o linklist.o preserve.o parser.o output.o dns_resolv.o graphs.o -lgd -lpng -lz -lm ld: warning prebinding disabled because dependent library: /opt/local/lib/libgd.2.dylib is not prebound ld: Undefined symbols: _libiconv _libiconv_close _libiconv_open make: * [webalizer] Error 1 Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_www_webalizer/work/webalizer-2.01-10" && make all" returned error 2 Command output: gcc -L/opt/local/lib -L/opt/local/lib -L/opt/local/lib -o webalizer webalizer.o hashtab.o linklist.o preserve.o parser.o output.o dns_resolv.o graphs.o -lgd -lpng -lz -lm ld: warning prebinding disabled because dependent library: /opt/local/lib/libgd.2.dylib is not prebound ld: Undefined symbols: _libiconv _libiconv_close _libiconv_open make: * [webalizer] Error 1

Warning: the following items did not execute (for webalizer): com.apple.activate com.apple.build com.apple.destroot com.apple.archive com.apple.install

Change History (4)

comment:1 Changed 15 years ago by mww@…

this is really strange: I just installed webalizer and it does NOT link against libiconv nor is it trying to here (though this is a 10.4 system).

comment:2 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to mike.mclean@…

comment:3 Changed 15 years ago by mww@…

Summary: 1.102 webalizer installation fails: ld: Undefined symbols: libiconvBUG: 1.102 webalizer installation fails: ld: Undefined symbols: libiconv

comment:4 Changed 15 years ago by mike.mclean@…

Resolution: worksforme
Status: newclosed

I can’t reproduce this on two different OS X systems. One is 10.3 server, one is 10.4.x on Intel MacBook Pro

Note: See TracTickets for help on using tickets.