Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#54078 closed defect (fixed)

gnuradio, gnuradio-devel: Build failure with cppunit 1.14.0

Reported by: mf2k (Frank Schima) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: dgmess01
Port: gnuradio

Description (last modified by mf2k (Frank Schima))

gnuradio-devel seems to be failing due to the latest cppunit. I am running macOS Sierra 10.12.4 with Xcode 8.3.2.

/opt/local/var/macports/build/_opt_local_var_macports_sources_github.com_macports_macports-ports_science_gnuradio/gnuradio-devel/work/gnuradio-082711cc3f7d910e50609695224e7a3c994a4c73/gnuradio-runtime/lib/math/qa_fxpt.h:32:3: note: in instantiation of member function 'CppUnit::TestCaller<qa_fxpt>::TestCaller' requested here
:info:build   CPPUNIT_TEST(t0);
:info:build   ^
:info:build /opt/local/include/cppunit/extensions/HelperMacros.h:299:15: note: expanded from macro 'CPPUNIT_TEST'
:info:build         ( new CPPUNIT_NS::TestCaller<TestFixtureType>(    \
:info:build               ^
:info:build /opt/local/include/cppunit/Portability.h:107:21: note: expanded from macro 'CPPUNIT_NS'
:info:build # define CPPUNIT_NS CppUnit
:info:build                     ^
:info:build /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/../include/c++/v1/algorithm:862:1: note: candidate function template not viable: requires 3 arguments, but 2 were provided
:info:build find(_InputIterator __first, _InputIterator __last, const _Tp& __value_)
:info:build ^
:info:build 4 errors generated.
:info:build make[2]: *** [gnuradio-runtime/lib/CMakeFiles/test-gnuradio-runtime.dir/math/qa_fxpt.cc.o] Error 1
$ port installed cppunit
The following ports are currently installed:
  cppunit @1.14.0_0 (active)

I have not tried to build gnuradio yet.

Attachments (2)

main.log (2.0 MB) - added by mf2k (Frank Schima) 2 years ago.
Python_2017-05-02-141123_Crux.crash (25.0 KB) - added by txjacob 2 years ago.

Change History (19)

Changed 2 years ago by mf2k (Frank Schima)

Attachment: main.log added

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:2 Changed 2 years ago by mf2k (Frank Schima)

Summary: gnuradio-devel: Build failure with cppunitgnuradio-devel: Build failure with cppunit 1.14.0

comment:3 Changed 2 years ago by michaelld (Michael Dickens)

The issue is the new CppUnit requires C++11, and its API also requires C++11 which means any dependency requires C++11. I'm working on fixing GNU Radio to require C++11 for building.

comment:4 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: dgmess01 added
Summary: gnuradio-devel: Build failure with cppunit 1.14.0gnuradio, gnuradio-devel: Build failure with cppunit 1.14.0

Has duplicate #54082.

comment:5 Changed 2 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:6 Changed 2 years ago by michaelld (Michael Dickens)

I forgot to note in the commit this ticket. This issue should be fixed in https://github.com/macports/macports-ports/commit/41b662b24380542114ab14a95e4ffb9ac9440662 . Please update your ports and verify.

Last edited 2 years ago by michaelld (Michael Dickens) (previous) (diff)

comment:7 Changed 2 years ago by txjacob

This may be related to the update to C++11, but now I get a Segfault 11 when I run gnuradio-companion after installing.

comment:8 Changed 2 years ago by michaelld (Michael Dickens)

Interesting. I'm guessing this is related to log4cpp. Can you attach the crash log?

comment:9 in reply to:  8 Changed 2 years ago by txjacob

Replying to michaelld:

Interesting. I'm guessing this is related to log4cpp. Can you attach the crash log?

Pardon my inexperience, but where do I find the crash log?

comment:10 Changed 2 years ago by michaelld (Michael Dickens)

Console.app . Maybe "User Reports" ... maybe try to search in it...

Changed 2 years ago by txjacob

comment:11 Changed 2 years ago by txjacob

Found it, and uploaded it.

comment:12 Changed 2 years ago by michaelld (Michael Dickens)

Yes: log4cpp. I'm working on getting that fixed too. One step at a time ... If you edit ~/.gnuradio/config.conf , there might be some "[LOG]" entries. Try setting them to "off" or "none" & see what happens when you execute GRC.

comment:13 in reply to:  12 Changed 2 years ago by txjacob

Replying to michaelld:

Yes: log4cpp. I'm working on getting that fixed too. One step at a time ... If you edit ~/.gnuradio/config.conf , there might be some "[LOG]" entries. Try setting them to "off" or "none" & see what happens when you execute GRC.

Still crashes when set to off. I'll just wait for you to fix it.

comment:14 Changed 2 years ago by michaelld (Michael Dickens)

ACK

comment:15 Changed 2 years ago by michaelld (Michael Dickens)

I just committed a fix to log4cpp that fixes this GNU Radio issue for me. Please update & see if it works for you.

See also: https://github.com/macports/macports-ports/commit/03e977add031301f57ca69729d829c607fe8d316

comment:16 Changed 2 years ago by michaelld (Michael Dickens)

comment:17 Changed 2 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed

Builds and gnuradio-companion works again. Thank you!

Last edited 2 years ago by mf2k (Frank Schima) (previous) (diff)
Note: See TracTickets for help on using tickets.