Opened 2 years ago

Closed 2 years ago

#54185 closed defect (duplicate)

py36-readline - malloc: *** error

Reported by: dylib Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.0
Keywords: Cc:
Port: py36-readline

Description

It appears py36-readline is badly broken:

$ sudo port install py36-readline
--->  Computing dependencies for py36-readline
--->  Fetching archive for py36-readline
--->  Attempting to fetch py36-readline-6.2.4.1_1.darwin_16.x86_64.tbz2 from https://packages.macports.org/py36-readline
--->  Attempting to fetch py36-readline-6.2.4.1_1.darwin_16.x86_64.tbz2 from http://fco.it.packages.macports.org/mirrors/macports-packages/py-readline/py36-readline
--->  Attempting to fetch py36-readline-6.2.4.1_1.darwin_16.x86_64.tbz2 from http://her.gr.packages.macports.org/py36-readline
--->  Fetching distfiles for py36-readline
--->  Verifying checksums for py36-readline
--->  Extracting py36-readline
--->  Applying patches to py36-readline
--->  Configuring py36-readline
--->  Building py36-readline
--->  Staging py36-readline into destroot
--->  Installing py36-readline @6.2.4.1_1
--->  Activating py36-readline @6.2.4.1_1
--->  Cleaning py36-readline
--->  Updating database of binaries
--->  Scanning binaries for linking errors
--->  No broken files found.

$ python3.6

Python 3.6.0 (default, Dec 23 2016, 12:50:55) 
[GCC 4.2.1 Compatible Apple LLVM 8.0.0 (clang-800.0.38)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> print("foo")
Python(311,0x7fffbd22c3c0) malloc: *** error for object 0x10d9a4110: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

Change History (2)

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Keywords: Python Readline removed
Priority: HighNormal

comment:2 Changed 2 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

Duplicate of #53360.

Note: See TracTickets for help on using tickets.