#54235 closed defect (fixed)

libzzip not found

Reported by: mrkapqa Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.4.1
Keywords: Cc: Schamschula (Marius Schamschula)
Port: libzzip

Description (last modified by ryandesign (Ryan Schmidt))

Hllo ,

i try to install MPlayer on osx 10.4

this error i get

--->  Computing dependencies for MPlayer
Error: Dependency 'libzzip' not found.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port mplayer failed
riks-imac-g5:~ rik$ sudo port install libzzip
Error: Port libzzip not found
riks-imac-g5:~ rik$ sudo port install mplayer
--->  Computing dependencies for MPlayer
Error: Dependency 'libzzip' not found.

installed the dependency manually from here

http://mail.zarahemla.com/software/pkgdetail.html?project_id=208&cat_id=200

but same error

Change History (5)

comment:1 Changed 22 months ago by kencu (Ken)

I have the last version of libzzip installed on Tiger PPC. I haven't updated it to the new version yet, as for Tiger, I tend to lag behind a bit on routinely updating things for no good reason as there are often errors to work out with new software.

$ port -v installed libzzip
Warning: port definitions are more than two weeks old, consider updating them by running 'port selfupdate'.
The following ports are currently installed:
  libzzip @0.13.62_1 (active) platform='darwin 8' archs='ppc' date='2017-02-08T14:12:49-0800'

Don't install it from a separate download site like that -- that will not (easily) work with MacPorts.

I don't understand why sudo port -v install libzzip would say Port libzzip not found. First thing I would think of would be to try syncing again sudo port sync and see if it magically reappears...

Last edited 22 months ago by kencu (Ken) (previous) (diff)

comment:2 Changed 22 months ago by Schamschula (Marius Schamschula)

The manually installed version is ancient. It may fail configure tests.

What version of MacPorts do you have installed? How long since you synced the Portfiles (i.e. did a port sync)?

comment:3 Changed 22 months ago by mrkapqa

thanks, it says : Macports base is already the latest version

sudo port -v install libzzip
Error: Port libzzip not found

sudo port install mplayer
--- computing dependencies for MPlayer ....
Error: Dependency 'libzzip' not found
Last edited 22 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:4 Changed 22 months ago by ryandesign (Ryan Schmidt)

Cc: Schamschula added
Description: modified (diff)
Keywords: mplayer tiger libzzip removed
Owner: set to ryandesign
Port: libzzip added; mplayer removed
Status: newaccepted
Summary: (10.4, mplayer) Dependency 'libzzip' not foundlibzzip not found

The port is not found because the portfile contains a syntax error on Snow Leopard and earlier, introduced in [9cf8dbd237d440b1faccd0d39ddc44816ed54ec6/macports-ports].

comment:5 Changed 22 months ago by Ryan Schmidt <git@…>

Resolution: fixed
Status: acceptedclosed

In b101c1902d9c4e9da434938488bba506a16bba53/macports-ports:

libzzip: Fix syntax error on Snow Leopard and earlier

Also ensure the OS is Darwin before we check its version number.

Closes: #54235

Note: See TracTickets for help on using tickets.