Opened 15 years ago

Closed 15 years ago

#5434 closed defect (duplicate)

BUG: fontconfig

Reported by: ben@… Owned by: blb@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

The fontconfig port requires port:freetype, but configure picks up /usr/X11R6/bin/freetype-config instead. I haven't noticed any symptoms yet (AFAIK), but I don't think this can be right...

10.4/DP1.1012/up-to-date ports. By the way, I have Fink's x.org package installed. Perhaps it's all my fault :-)

[Bugzilla says blb@… 'doesn't match anything' so I assigned to Toby.]

Attachments (1)

tmp (6.8 KB) - added by ben@… 15 years ago.
build log

Download all attachments as: .zip

Change History (6)

Changed 15 years ago by ben@…

Attachment: tmp added

build log

comment:1 Changed 15 years ago by blb@…

Cc: blb@… added

(In reply to comment #0)

The fontconfig port requires port:freetype, but configure picks up /usr/X11R6/bin/freetype-config instead. I haven't noticed any symptoms yet (AFAIK), but I don't think this can be right...

Weird, a quick check shows my fontconfig to be linked against DP's freetype:

$ otool -L /opt/local/lib/libfontconfig.1.dylib /opt/local/lib/libfontconfig.1.dylib:

/opt/local/lib/libfontconfig.1.dylib (compatibility version 2.0.0, current version 2.4.0) /opt/local/lib/libfreetype.6.dylib (compatibility version 10.0.0, current version 10.7.0)

...

I trust /opt/local/bin/freetype-config does exist and is executable?

[Bugzilla says blb@… 'doesn't match anything' so I assigned to Toby.]

You must have caught me in between changing all my ports to @opendarwin...

comment:2 Changed 15 years ago by ben@…

(In reply to comment #2)

Weird, a quick check shows my fontconfig to be linked against DP's freetype:

eep. Mine is too (despite the configure output I attached):

[ben@assam kdebase3] $ otool -L /opt/local/lib/libfontconfig.1.dylib /opt/local/lib/libfontconfig.1.dylib:

/opt/local/lib/libfontconfig.1.dylib (compatibility version 2.0.0,

current version 2.4.0)

/opt/local/lib/libfreetype.6.dylib (compatibility version 10.0.0,

current version 10.7.0)

I'm not sure if that makes it worse or better... :-)

comment:3 Changed 15 years ago by mww@…

Owner: changed from toby@… to blb@…

comment:4 Changed 15 years ago by blb@…

Cc: blb@… removed

That's definitely weird. A quick run of configure here shows the DP-installed freetype-config being properly picked up instead of the X11 default.

You wouldn't, by chance, have set binpath in your ports.conf to have /usr/X11/bin before /opt/local/ bin, did you?

comment:5 Changed 15 years ago by blb@…

Resolution: duplicate
Status: newclosed

Definitely the PATH issue as seen by several and in bug 5435.

* This bug has been marked as a duplicate of 5435 *

Note: See TracTickets for help on using tickets.