Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#54562 closed defect (worksforme)

codeblocks @16.01-11098: Failed to fetch codeblocks: Subversion check out failed

Reported by: jkulesza (Joel A. Kulesza) Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version: 2.4.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: codeblocks

Description

See attached log file.

The fetch failure is non-descript; however, I am behind a proxy. Could that be the cause?

Attachments (1)

jkulesza_codeblocks_main.log (49.6 KB) - added by jkulesza (Joel A. Kulesza) 3 years ago.

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by jkulesza (Joel A. Kulesza)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Cc: mojca removed
Owner: set to mojca
Status: newassigned

comment:2 in reply to:  description Changed 3 years ago by ryandesign (Ryan Schmidt)

Replying to jkulesza:

The fetch failure is non-descript; however, I am behind a proxy. Could that be the cause?

Sure. How have you configured your proxy? MacPorts should get your proxy configuration from System Preferences > Network, but if not, you can inform MacPorts of it directly in macports.conf.

However, this port does not fetch using a protocol that is typically proxied, like http; instead it fetches using the svn protocol. Maybe the problem could be resolved by switching the port to fetch via http(s), if available.

comment:3 Changed 3 years ago by mojca (Mojca Miklavec)

Resolution: worksforme
Status: assignedclosed

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added

Is there a reason why we fetch from svn instead of using the source tarballs?

comment:5 Changed 3 years ago by mojca (Mojca Miklavec)

16.01 had so many problems that it was hopeless to backport all the patches that were fixed in the meantime. 17.12 apparently came out three weeks ago, I was not even aware of it. I tried updating to a newer version of svn at some point, but I bumped into other problems (I was using an older OS back then when I tried and I probably had countless issues with C++11 etc.). At this point it would surely be much better to go for the released version.

Note: See TracTickets for help on using tickets.