Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#5460 closed defect (fixed)

BUG: libgnomeprint fails parse.l:44: error: conflicting types for 'YYSTYPE'

Reported by: bellenot@… Owned by: gnome-darwinports@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: wingdo@…
Port:

Description

libgnomeprint fails (see log below). It looks to me like the error is that an include file "grammer.tab.h" is being included "twice" in the file lex._gnome_print_filter_parse_yy.c. Once as a #include and once copied as text at the end of this file. Or at the URL http://www.math.fsu.edu/~bellenot/libgnomeprint.txt

bellenot 233> uname -a Darwin mac228.math.fsu.edu 8.2.0 Darwin Kernel Version 8.2.0: Fri Jun 24 17:46:5 4 PDT 2005; root:xnu-792.2.4.obj~3/RELEASE_PPC Power Macintosh powerpc

More lines at URL

---> Attempting to fetch libgnomeprint-2.12.1.tar.bz2 from http://www.gtlib.cc. gatech.edu/pub/gnome/sources/libgnomeprint/2.12/ ---> Verifying checksum(s) for libgnomeprint ---> Extracting libgnomeprint ---> Configuring libgnomeprint ---> Building libgnomeprint with target all ---> Staging libgnomeprint into destroot Error: Target com.apple.destroot returned: shell command "cd "/opt/local/var/db/

... clip ... see url for full text ...

Making install in ttsubset make[3]: Nothing to be done for `install-exec-am'. make[3]: Nothing to be done for `install-data-am'. Making install in . /usr/bin/flex -P_gnome_print_filter_parse_yy parse.l grammar.tab.h if /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/op t/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include/ libart-2.0 -I/opt/local/include/pango-1.0 -I/opt/local/include -I/opt/local/incl ude/freetype2 -I/opt/local/include/libxml2 -I/opt/local/include/freetype2 -I/o pt/local/include -DG_LOG_DOMAIN=\"GnomePrint\" -DGNOMELOCALEDIR=\""/opt/local/sh are/locale"\" -DGNOME_PRINT_DATA_DIR=\""/opt/local/share/libgnomeprint/2.12.1"\"

-DGNOME_PRINT_MODULES_DIR=\""/opt/local/lib/libgnomeprint/2.12.1/modules"\" -I

/opt/local/include -L/opt/local/lib -g -O2 -MT lex._gnome_print_filter_parse_y y.lo -MD -MP -MF ".deps/lex._gnome_print_filter_parse_yy.Tpo" \

-c -o lex._gnome_print_filter_parse_yy.lo `test -f 'lex._gnome_print_filter_pa

rse_yy.c'
echo './'`lex._gnome_print_filter_parse_yy.c; \

then mv -f ".deps/lex._gnome_print_filter_parse_yy.Tpo" ".deps/lex._gnome_print_ filter_parse_yy.Plo"; \ else rm -f ".deps/lex._gnome_print_filter_parse_yy.Tpo"; exit 1; \ fi

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/opt/local/include/glib-2.0 -I/opt/loca

l/lib/glib-2.0/include -I/opt/local/include/libart-2.0 -I/opt/local/include/pang o-1.0 -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/l ibxml2 -I/opt/local/include/freetype2 -I/opt/local/include -DG_LOG_DOMAIN=\"Gnom ePrint\" -DGNOMELOCALEDIR=\"/opt/local/share/locale\" -DGNOME_PRINT_DATA_DIR=\"/ opt/local/share/libgnomeprint/2.12.1\" -DGNOME_PRINT_MODULES_DIR=\"/opt/local/li b/libgnomeprint/2.12.1/modules\" -I/opt/local/include -L/opt/local/lib -g -O2 -M T lex._gnome_print_filter_parse_yy.lo -MD -MP -MF .deps/lex._gnome_print_filter_ parse_yy.Tpo -c lex._gnome_print_filter_parse_yy.c -fno-common -DPIC -o .libs/l ex._gnome_print_filter_parse_yy.o parse.l:44: error: conflicting types for 'YYSTYPE' ../libgnomeprint/grammar.tab.h:6: error: previous declaration of 'YYSTYPE' was h ere make[2]: * [lex._gnome_print_filter_parse_yy.lo] Error 1 make[1]: * [install-recursive] Error 1 make: * [install-recursive] Error 1

Error: The following dependencies failed to build: goffice libgnomeprintui libgn omeprint libgsf gnome-vfs gnome-mime-data

Change History (11)

comment:1 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to gnome-darwinports@…
Summary: libgnomeprint fails parse.l:44: error: conflicting types for 'YYSTYPE'BUG: libgnomeprint fails parse.l:44: error: conflicting types for 'YYSTYPE'

comment:2 Changed 15 years ago by suhlhorn@…

I have this same error on OS X 10.3.9. Has any progress been made?

comment:3 Changed 15 years ago by wsimpson@…

blocked: 5537

comment:4 Changed 15 years ago by wsimpson@…

confirmed. it apparently requires bison 2.1, which should be in the depends.

The workaround is

'port install bison' 'port clean libgnomeprint' 'port install libgnomeprint'

comment:5 Changed 15 years ago by wsimpson@…

blocked: 5557

comment:6 Changed 15 years ago by pkern@…

Please insert a "depends_build port:bison" into gnome/libgnomeprint/Portfile. The GNU bison 1.28 provided by OS X.4 is certainly not enough, the one provided by dports should be used in any case.

comment:7 Changed 15 years ago by suhlhorn@…

(In reply to comment #2)

confirmed. it apparently requires bison 2.1, which should be in the depends.

The workaround is

'port install bison' 'port clean libgnomeprint' 'port install libgnomeprint'

I tried this workaround, but got build errors fro gnumeric:

checking for glib-2.0 >= 2.6.0 gmodule-no-export-2.0 >= 2.6.0 gthread-2.0 >= 2.6.0 libxml-2.0 >= 2.6.0... yes checking MODULES_XML_CFLAGS... -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include/libxml2 -I/opt/local/include checking MODULES_XML_LIBS... -L/opt/local/lib -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 -lintl -lxml2 -lpthread -lz -liconv -lm checking for glib-2.0 >= 2.6.0 gmodule-no-export-2.0 >= 2.6.0 gthread-2.0 >= 2.6.0 gobject-2.0 >= 2.6.0... yes checking MODULES_CFLAGS... -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include checking MODULES_LIBS... -L/opt/local/lib -lgmodule-2.0 -lgthread-2.0 -lgobject-2.0 -lglib-2.0 -lintl -liconv checking for glib-2.0 >= 2.6.0 gmodule-no-export-2.0 >= 2.6.0 gthread-2.0 >= 2.6.0 gobject-2.0 >= 2.6.0 gconf-2.0 >= 1.1.1... Package gconf-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gconf-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gconf-2.0' found configure: error: Library requirements (glib-2.0 >= 2.6.0 gmodule-no-export-2.0

2.6.0 gthread-2.0 >= 2.6.0 gobject-2.0 >= 2.6.0 gconf-2.0 >= 1.1.1) not met;

consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

Error: The following dependencies failed to build: goffice libgsf gnome-vfs

comment:8 Changed 15 years ago by rhwood@…

It appears that the error with Gnumeric is from not installing the gconf2 package. Try explicitly installing that package to fix the gnumeric build problem.

comment:9 Changed 15 years ago by rhwood@…

Committing Portfile with an explicit dependency on bison.

comment:10 Changed 15 years ago by rhwood@…

Resolution: fixed
Status: newclosed

comment:11 Changed 15 years ago by rhwood@…

Cc: wingdo@… added

* Bug 5537 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.