Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#54669 closed defect (duplicate)

poppler 0.57.0 does not upgrade from poppler @0.56.0_0

Reported by: Zweihorn (@Zweihorn) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.4.1
Keywords: Cc: Zweihorn (@Zweihorn)
Port: poppler

Description

today the usual port upgrade outdated failed with:

Error: Failed to build poppler: command execution failed

during the upgrade to current port poppler 0.57.0 from poppler @0.56.0_0

the reason seems to be

:info:build dyld: Library not loaded: /opt/local/lib/libssl.1.0.0.dylib
:info:build   Referenced from: /opt/local/lib/libcurl.4.dylib

an excerpt from /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/main.log reads:

:info:build g-ir-scanner: link: /bin/sh ../libtool --mode=link --tag=CC /usr/bin/clang -arch x86_64 -o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib/tmp-introspectpUHJBU/Poppler-0.18 -export-dynamic -I/opt/local/include -Wall -pipe -Os -arch x86_64 tmp-introspectpUHJBU/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib/tmp-introspectpUHJBU/Poppler-0.18.o -L. libpoppler-glib.la ../poppler/libpoppler.la ../poppler/libpoppler-cairo.la -L/opt/local/lib -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -Wl,-framework -Wl,CoreFoundation -L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64
:info:build libtool: link: /usr/bin/clang -arch x86_64 -o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib/tmp-introspectpUHJBU/.libs/Poppler-0.18 -I/opt/local/include -Wall -pipe -Os -arch x86_64 tmp-introspectpUHJBU/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib/tmp-introspectpUHJBU/Poppler-0.18.o -Wl,-framework -Wl,CoreFoundation -Wl,-headerpad_max_install_names -arch x86_64  -L. ./.libs/libpoppler-glib.dylib -L/opt/local/lib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/poppler/.libs/libpoppler.dylib -lcairo ../poppler/.libs/libpoppler.dylib -llcms2 -ltiff -ljpeg -lpng16 -lcurl -lopenjp2 -lfontconfig -lfreetype ../poppler/.libs/libpoppler-cairo.a -lz -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -pthread
:info:build clang: warning: argument unused during compilation: '-pthread' [-Wunused-command-line-argument]
:info:build dyld: Library not loaded: /opt/local/lib/libssl.1.0.0.dylib
:info:build   Referenced from: /opt/local/lib/libcurl.4.dylib
:info:build   Reason: image not found
:info:build Command '[u'/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib/tmp-introspectpUHJBU/Poppler-0.18', u'--introspect-dump=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib/tmp-introspectpUHJBU/functions.txt,/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib/tmp-introspectpUHJBU/dump.xml']' returned non-zero exit status -6
:info:build make[4]: *** [Poppler-0.18.gir] Error 1
:info:build make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib'
:info:build make[3]: *** [all-recursive] Error 1
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib'
:info:build make[2]: *** [all] Error 2
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0/glib'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/poppler-0.57.0" && /usr/bin/make -j4 -w all CC="/usr/bin/clang -arch x86_64" 
:info:build Exit code: 2

an investigating shows installed libs are

  • /opt/local/lib/libssl.43.dylib
  • /opt/local/lib/libssl.a
  • /opt/local/lib/libssl.dylib
  • /opt/local/lib/libcurl.4.dylib
  • /opt/local/lib/libcurl.a
  • /opt/local/lib/libcurl.dylib

so libssl.1.0.0.dylib is missing

a reduced list of my installed ports:

  • libtool @2.4.6_3 (active)
  • libressl @2.5.5_0 (active)
  • curl @7.54.1_0+ssl
  • curl @7.55.1_0+ssl (active)
  • curl-ca-bundle @7.54.1_1
  • curl-ca-bundle @7.55.1_0 (active)
  • poppler @0.56.0_0 (active)
  • poppler-data @0.4.7_0
  • poppler-data @0.4.8_0 (active)

first guess: could a symbol link from new libssl.1.0.0.dylib to target libssl.dylib help?

what would be the appropriate port to improve? poppler? libressl?

Change History (7)

comment:1 Changed 5 years ago by kencu (Ken)

openssl provides /opt/local/lib/libssl.1.0.0.dylib. Does libressl not have that?

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Keywords: poppler libcurl libssl removed
Owner: set to dbevans
Status: newassigned

comment:3 Changed 5 years ago by Zweihorn (@Zweihorn)

Cc: Zweihorn added

comment:4 in reply to:  1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Replying to kencu:

openssl provides /opt/local/lib/libssl.1.0.0.dylib. Does libressl not have that?

No, it does not; libressl provides /opt/local/lib/libssl.43.dylib.

Our handling of libressl in MacPorts is flawed, in my opinion. As we can see, libressl is not a drop-in replacement for openssl, and MacPorts ports that depend on openssl should not, as they currently do, pretend that it is.

comment:5 Changed 5 years ago by ryandesign (Ryan Schmidt)

See #54744

comment:6 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: duplicate
Status: assignedclosed

Just considering this a dupe of #54744.

Please just stick with libressl and rebuild ports that are dependent on it.

comment:7 Changed 5 years ago by janstary (Jan Starý)

Tis os not one of those OpenSSL vs LibreSSL situations: curl will happily be rebuilt against LibreSSL, without change. (I had the very same problem.)

Note: See TracTickets for help on using tickets.