Opened 4 years ago

Closed 19 hours ago

#54692 closed defect (fixed)

advancemame: Update to version 3.5

Reported by: mf2k (Frank Schima) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.99
Keywords: Cc:
Port: advancemame

Description

I am attempting to update advancemame to the latest version. But I am stuck on the following configure error:

:debug:configure system:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_github.com_macports_macports-ports_emulators_advancemame/advancemame/work/advancemame-3.5" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man --with-sdl2-prefix=/opt/local --enable-asm=no 
:info:configure configure: error: cannot find install-sh, install.sh, or shtool in "." "./.." "./../.."

Attaching a diff for my non-working Portfile. Fixes welcome.

Attachments (3)

Portfile-advancemame.diff (1.6 KB) - added by mf2k (Frank Schima) 4 years ago.
Portfile-advancemame.2.diff (2.7 KB) - added by mf2k (Frank Schima) 4 years ago.
latest version
main.log (812.6 KB) - added by mf2k (Frank Schima) 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by mf2k (Frank Schima)

Attachment: Portfile-advancemame.diff added

Changed 4 years ago by mf2k (Frank Schima)

Attachment: Portfile-advancemame.2.diff added

latest version

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Thanks to jmroot for the suggestions, this update gets past configure, but hits a build error:

:info:build srcmess/artwork.c:2307:61: error: incomplete definition of type 'struct png_info_def'
:info:build         if (png.height != original->height || png.width != original->width)
:info:build                                                            ~~~~~~~~^
:info:build /opt/local/include/png.h:484:16: note: forward declaration of 'struct png_info_def'
Last edited 4 years ago by mf2k (Frank Schima) (previous) (diff)

Changed 4 years ago by mf2k (Frank Schima)

Attachment: main.log added

comment:2 Changed 4 years ago by kencu (Ken)

I don't know how old this software is, but this error looks like the errors that were seen when libpng updated to 1.5 and changed it API...

35949

52190

comment:3 Changed 4 years ago by mf2k (Frank Schima)

The latest version was released April 6, 2017. So it is not that old.

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

And yet the source file in question, srcmess/artwork.c, has a copyright date of 2006, at which time libpng version 1.2 was current, so the code may need to be updated for later versions of libpng.

Also, because in the pre-configure block you're copying files provided by automake, you need to add a build dependency on automake.

comment:5 Changed 3 years ago by mf2k (Frank Schima)

@ryandesign: Thanks for the comments. Exactly, their code needs to be updated for newer libpng. Unless I'm missing something, automake is already there as a build dependency in my patch. use_autoreconf yes brings it in.

comment:6 Changed 19 hours ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed

Updated at some point. It is at version 3.9 currently.

Note: See TracTickets for help on using tickets.