Opened 3 months ago

Last modified 3 months ago

#54753 assigned defect

py27-cryptography fails to build on Snow Leopard

Reported by: jsalort (Julien Salort) Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version: 2.4.1
Keywords: snowleopard Cc:
Port: py-cryptography

Description

MacPorts Version: 2.4.1 on Snow Leopard. Trying to build py27-cryptography 2.0.3_0. (Version 1.9_0 compiled fine)

It appears to fail because of an option passed to the compiler which is not supported by the default compiler:

/usr/bin/gcc-4.2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -arch x86_64 -I/opt/local/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c build/temp.macosx-10.6-x86_64-2.7/_openssl.c -o build/temp.macosx-10.6-x86_64-2.7/build/temp.macosx-10.6-x86_64-2.7/_openssl.o -Wconversion -Wno-error=sign-conversion
:info:build cc1: error: -Werror=sign-conversion: No option -Wsign-conversion
:info:build error: command '/usr/bin/gcc-4.2' failed with exit status 1

I suppose there may be a way to workaround this problem but I don't know how to prevent Macports from passing this option, or have py27-cryptography builds with another compiler.

Attachments (1)

main.log (20.2 KB) - added by jsalort (Julien Salort) 3 months ago.

Download all attachments as: .zip

Change History (4)

Changed 3 months ago by jsalort (Julien Salort)

comment:1 Changed 3 months ago by mf2k (Frank Schima)

  • Cc stromnov removed
  • Owner set to stromnov
  • Port py-cryptography added; py27-cryptography removed
  • Status changed from new to assigned

comment:2 Changed 3 months ago by mf2k (Frank Schima)

  • Keywords snowleopard added

comment:3 Changed 3 months ago by kencu (Ken)

looks like a duplicate of 54519, and Peter has a patch in that ticket that might fix this.

Last edited 3 months ago by kencu (Ken) (previous) (diff)
Note: See TracTickets for help on using tickets.