Opened 14 months ago

Closed 14 months ago

Last modified 12 months ago

#54829 closed defect (fixed)

libgcc, libgcc-devel, libgcc6: fatal error: bits/locale_facets.h: No such file or directory

Reported by: braslau Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.1
Keywords: highsierra Cc: jeremyhu (Jeremy Huddleston Sequoia), mojca (Mojca Miklavec), Schamschula (Marius Schamschula), grimreaper (Eitan Adler), sbutler (Stephen J. Butler), skymoo (Adam Mercer), maehne (Torsten Maehne)
Port: libgcc, libgcc-devel, libgcc6

Description

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/./gcc/xgcc -shared-libgcc -B/opt/local/var/macports/build/_
opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/./gcc -nostdinc++ -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/src -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/src/.libs -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/libsupc++/.libs -B/opt/local/x86_64-apple-darwin17/bin/ -B/opt/local/x86_64-apple-darwin17/lib/ -isystem /opt/local/x86_64-apple-darwin17/include -isystem /opt/local/x86_64-apple-darwin17/sys-include    -x c++-header -nostdinc++ -g -O2 -pipe -Os  -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include/x86_64-apple-darwin17 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/gcc-6.4.0/libstdc++-v3/libsupc++  -O2 -g /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/gcc-6.4.0/libstdc++-v3/include/precompiled/stdc++.h -o x86_64-apple-darwin17/bits/stdc++.h.gch/O2g.gch
:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include/ios:44:0,
:info:build                  from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include/istream:38,
:info:build                  from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include/sstream:38,
:info:build                  from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include/complex:45,
:info:build                  from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include/ccomplex:39,
:info:build                  from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/gcc-6.4.0/libstdc++-v3/include/precompiled/stdc++.h:52:
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include/bits/basic_ios.h:37:32: fatal error: bits/locale_facets.h: No such file or directory
:info:build  #include <bits/locale_facets.h>
:info:build                                 ^

Attachments (1)

main.log.xz (161.5 KB) - added by braslau 14 months ago.

Download all attachments as: .zip

Change History (21)

Changed 14 months ago by braslau

Attachment: main.log.xz added

comment:1 Changed 14 months ago by mf2k (Frank Schima)

Keywords: highsierra added; High Sierra removed

comment:2 Changed 14 months ago by Schamschula (Marius Schamschula)

Cc: Schamschula added

comment:3 Changed 14 months ago by grimreaper (Eitan Adler)

Cc: grimreaper added

comment:4 Changed 14 months ago by ryandesign (Ryan Schmidt)

Summary: libgcc6 - fatal error: bits/locale_facets.h: No such file or directorylibgcc6 @6.4.0: fatal error: bits/locale_facets.h: No such file or directory

comment:5 Changed 14 months ago by jeremyhu (Jeremy Huddleston Sequoia)

This looks to be an upstream bug that is revealed by APFS. For now, please just retry the build to continue building.

comment:6 Changed 14 months ago by mojca (Mojca Miklavec)

It seemed strange to me indeed that when we continued building manually, the build would sometimes succeed.

comment:7 Changed 14 months ago by sbutler (Stephen J. Butler)

Cc: sbutler added

comment:8 Changed 14 months ago by bigmoe

Reproduced similar issues with (lib)gcc6, gcc7, and gcc8. Running High Sierra on an APFS SSD with Xcode 9.

libgcc6:

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_gcc6/libgcc6/work/build/x86_64-apple-darwin17/libstdc++-v3/include/istream:39:19: fatal error: ostream: No such file or directory

gcc7:

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_gcc7/gcc7/work/gcc-7.2.0/libstdc++-v3/include/precompiled/stdc++.h:46:10: fatal error: cstdio: No such file or directory

gcc8 (beta)

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_gcc8/libgcc-devel/work/build/x86_64-apple-darwin17/libstdc++-v3/include/unordered_map:47:10: fatal error: bits/hashtable.h: No such file or directory

comment:9 Changed 14 months ago by kencu (Ken)

see also 54900. It looks like a race condition on APFS. You should be able to fix it short term by disabling parallel builds in the Portfile

use_parallel_build  yes

to

use_parallel_build  no

-- more elegant would be to disable parallel building just in the part of the build where there is a problem, as per that other ticket.

Last edited 14 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:10 Changed 14 months ago by cjones051073 (Chris Jones)

See #54900 for a different fix.... Only seems to work on gcc7 though.

Last edited 14 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:11 in reply to:  6 Changed 14 months ago by cjones051073 (Chris Jones)

Replying to mojca:

It seemed strange to me indeed that when we continued building manually, the build would sometimes succeed.

Not so strange when you read up on how foobarr'ed gcc's build system is in https://gcc.gnu.org/bugzilla/show_bug.cgi?id=81797

Last edited 14 months ago by cjones051073 (Chris Jones) (previous) (diff)

comment:12 Changed 14 months ago by cjones051073 (Chris Jones)

Turning off parallel builds worked for me with gcc6. Slow as heck, but worked...

comment:13 Changed 14 months ago by jeremyhu (Jeremy Huddleston Sequoia)

No need to do that... retry your 'sudo port -s upgrade ...' command and it'll pick up where it left off successfully...

comment:14 Changed 14 months ago by ryandesign (Ryan Schmidt)

Cc: skymoo added
Port: libgcc libgcc-devel added
Summary: libgcc6 @6.4.0: fatal error: bits/locale_facets.h: No such file or directorylibgcc, libgcc-devel, libgcc6: fatal error: bits/locale_facets.h: No such file or directory

Has duplicate #54916.

comment:15 Changed 14 months ago by maehne (Torsten Maehne)

Cc: maehne added

comment:16 Changed 14 months ago by cjones051073 (Chris Jones)

comment:17 Changed 14 months ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: newclosed

comment:18 Changed 13 months ago by ryandesign (Ryan Schmidt)

In 61e9526f91b4603a41251f7f3285cc9d38521838/macports-ports:

gcc[5-8]: Reenable parallel building on High Sierra

Disable parallel building only for the headers. That part of the build
appears to have been implemented in a buggy way that APFS exposes.

See: #54829
See: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=81797

comment:19 Changed 13 months ago by mojca (Mojca Miklavec)

The same problem affects the crossgcc PortGroup.

Crosscompilers seem to fail in the same way. Ryan, would you be willing to look into this and try to patch it in a similar way?

See #55213.

Last edited 13 months ago by mojca (Mojca Miklavec) (previous) (diff)

comment:20 Changed 12 months ago by mojca (Mojca Miklavec)

In ba22aca61d380c224915cb94c5a553c0ab145759/macports-ports:

*-w64-mingw32-gcc: workaround for builds on APFS

Patch copied from the gcc7 port.

See: #54829
See: #55213
See: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=81797

Note: See TracTickets for help on using tickets.