Opened 3 years ago

Closed 3 years ago

#54898 closed defect (fixed)

osxfuse: checksum failure

Reported by: jcchancellor Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.4.1
Keywords: Cc:
Port: osxfuse

Description (last modified by mf2k (Frank Schima))

I am trying to install sshfs and I receive a message that the required dependancy, osxfuse, will not build because of a failed checksum. The log output follows:

sudo port -v install sshfs
--->  Computing dependencies for sshfs..
The following dependencies will be installed:  osxfuse
Continue? [Y/n]: y
--->  Verifying checksums for osxfuse
--->  Checksumming osxfuse-431bdc5.tar.gz
--->  Checksumming kext-0a73539.tar.gz
--->  Checksumming framework-e1df643.tar.gz
--->  Checksumming prefpane-8a65eb2.tar.gz
Error: Checksum (rmd160) mismatch for prefpane-8a65eb2.tar.gz
Portfile checksum: prefpane-8a65eb2.tar.gz rmd160 cdf12079ce6ed657b11814c5d1aba1f698f210eb
Distfile checksum: prefpane-8a65eb2.tar.gz rmd160 2527eee92d1634b811e6be9aab9b93c42f08d4e7
Error: Checksum (sha256) mismatch for prefpane-8a65eb2.tar.gz
Portfile checksum: prefpane-8a65eb2.tar.gz sha256 45510edfbfbc8d430fa06f8bc3f4f1d5db943c84c2e93445fa64224f742d4124
Distfile checksum: prefpane-8a65eb2.tar.gz sha256 9227d2e309fcab59fb4ea342b5b72d9e1eee5e1de430e1e45175f0f9f50d1f34
--->  Checksumming fuse-559738e.tar.gz
--->  Checksumming support-19b4e8b.tar.gz
--->  Checksumming osxfuse-3.7.1.dmg
The correct checksum line may be:
checksums           osxfuse-431bdc5.tar.gz \
                    rmd160  71feaf83788bc2d1a862dd603993dab06f18e0e4 \
                    sha256  4e93768fd8276bf458c237ee298db659e412cff26362ee13a0789000e387f7b5 \
                    kext-0a73539.tar.gz \
                    rmd160  8e05632c0e27528845115c51cddcc074b0555720 \
                    sha256  48bf4a9a6befed3a710f3254f5572891e7c5e6b2e637e2ee70a222882864bedf \
                    framework-e1df643.tar.gz \
                    rmd160  6b929ca95d19636a84c3c6805b6bb4afad7af0c1 \
                    sha256  7a9946a7bd5b29e0c826be267ccdbcce98f8c2946b8aea355ed9257d28c359a9 \
                    prefpane-8a65eb2.tar.gz \
                    rmd160  2527eee92d1634b811e6be9aab9b93c42f08d4e7 \
                    sha256  9227d2e309fcab59fb4ea342b5b72d9e1eee5e1de430e1e45175f0f9f50d1f34 \
                    fuse-559738e.tar.gz \
                    rmd160  97ebdbf37f84035400666f7252c67313700db494 \
                    sha256  32818f955c7179987bee8b4187e23a00763d43e19759190956b92740b673cb94 \
                    support-19b4e8b.tar.gz \
                    rmd160  26028986b1dac72789be9bf760f40afe00e79a1a \
                    sha256  5a606d9f9d3a652d20c4e23efca5638edde0b70c24d0a85ec21fc1ddd0395da9 \
                    osxfuse-3.7.1.dmg \
                    rmd160  b63fdf2dae4dbe8f95e52b38f2f310fbb7c7164f \
                    sha256  0982bca1661d1b8df1c310e828984b25c11dfdc623a79566bfa6283779fad24c
Error: Failed to checksum osxfuse: Unable to verify file checksums
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port sshfs failed

Change History (4)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Keywords: sshfs osxfuse removed
Owner: set to drkp
Port: osxfuse added; sshfs removed
Status: newassigned
Summary: building sshfs fails because of osxfuse dependancyosxfuse: checksum failure

In the future, please use WikiFormatting, fill in the Port field with the port that actually fails to build and Cc that port's maintainers (port info --maintainers osxfuse), if any.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 3 years ago by raimue (Rainer Müller)

As these downloads are tarballs generated by GitHub, the mismatch is most likely caused by their update as described in #54839.

comment:4 Changed 3 years ago by Dan R. K. Ports <drkp@…>

Resolution: fixed
Status: assignedclosed

In 7c281354f28c9ddbcdb19dddec135e7df2f030ff/macports-ports:

osxfuse: set dist_subdir to prevent github-caused checksum mismatch

See #54839
Closes: #54892
Closes: #54898

Note: See TracTickets for help on using tickets.