Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#54924 closed defect (duplicate)

libnetpbm: svn checkout fails

Reported by: fazilz (Fazil Zuhaib) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.1
Keywords: Cc: gallafent
Port: libnetpbm

Description

main log file.

version:1
:debug:main Found Dependency: path: /usr/bin filename: svn regex: ^svn$
:msg:main --->  Computing dependencies for libnetpbm:info:main .:debug:main libnetpbm has no conflicts
:debug:main Found Dependency: path: /usr/bin filename: svn regex: ^svn$
:debug:main Searching for dependency: subversion
:debug:main Didn't find receipt, going to depspec regex for: subversion
:debug:main Found Dependency: path: /usr/bin filename: svn regex: ^svn$
:debug:main Executing org.macports.main (libnetpbm)
:debug:main dropping privileges: euid changed to 502, egid changed to 501.
:debug:archivefetch archivefetch phase started at Wed Sep 27 17:16:40 EDT 2017
:msg:archivefetch --->  Fetching archive for libnetpbm
:debug:archivefetch Executing org.macports.archivefetch (libnetpbm)
:debug:archivefetch euid/egid changed to: 0/0
:debug:archivefetch chowned /opt/local/var/macports/incoming to macports
:debug:archivefetch euid/egid changed to: 502/501
:info:archivefetch --->  libnetpbm-10.79.07_0.darwin_17.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/verified
:msg:archivefetch --->  Attempting to fetch libnetpbm-10.79.07_0.darwin_17.x86_64.tbz2 from https://packages.macports.org/libnetpbm
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch libnetpbm-10.79.07_0.darwin_17.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/libnetpbm
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch libnetpbm-10.79.07_0.darwin_17.x86_64.tbz2 from http://lil.fr.packages.macports.org/libnetpbm
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 Not Found
:debug:archivefetch Privilege de-escalation not attempted as not running as root.
:debug:fetch fetch phase started at Wed Sep 27 17:16:41 EDT 2017
:notice:fetch --->  Fetching distfiles for libnetpbm
:debug:fetch Executing org.macports.fetch (libnetpbm)
:debug:fetch Environment: 
:debug:fetch CC_PRINT_OPTIONS='YES'
:debug:fetch CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work/.CC_PRINT_OPTIONS'
:debug:fetch CPATH='/opt/local/include'
:debug:fetch LIBRARY_PATH='/opt/local/lib'
:debug:fetch MACOSX_DEPLOYMENT_TARGET='10.13'
:info:fetch Executing:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work" && /usr/bin/svn --non-interactive --trust-server-cert checkout https://svn.code.sf.net/p/netpbm/code/@3064 --non-recursive /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work 2>&1
:debug:fetch system:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work" && /usr/bin/svn --non-interactive --trust-server-cert checkout https://svn.code.sf.net/p/netpbm/code/@3064 --non-recursive /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work 2>&1
:info:fetch Checked out revision 3064.
:debug:fetch Executing proc-post-org.macports.fetch-fetch-0
:debug:fetch system -W /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work: /usr/bin/svn --non-interactive --trust-server-cert update -r3064 advanced userguide 
:info:fetch Updating 'advanced':
:info:fetch svn: E170013: Unable to connect to a repository at URL 'https://svn.code.sf.net/p/netpbm/code'
:info:fetch svn: E160013: '/p/netpbm/code' path not found
:info:fetch Command failed: /usr/bin/svn --non-interactive --trust-server-cert update -r3064 advanced userguide 
:info:fetch Exit code: 1
:error:fetch Failed to fetch libnetpbm: command execution failed
:debug:fetch Error code: NONE
:debug:fetch Backtrace: command execution failed
:debug:fetch     while executing
:debug:fetch "$post $targetname"
:error:fetch See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/main.log for details.
version:1
:debug:main Found Dependency: path: /usr/bin filename: svn regex: ^svn$
:msg:main --->  Computing dependencies for libnetpbm:info:main .:debug:main libnetpbm has no conflicts
:debug:main Found Dependency: path: /usr/bin filename: svn regex: ^svn$
:debug:main Searching for dependency: subversion
:debug:main Didn't find receipt, going to depspec regex for: subversion
:debug:main Found Dependency: path: /usr/bin filename: svn regex: ^svn$
:debug:main Executing org.macports.main (libnetpbm)
:debug:main dropping privileges: euid changed to 502, egid changed to 501.
:debug:main Skipping completed org.macports.archivefetch (libnetpbm)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:fetch fetch phase started at Wed Sep 27 17:20:19 EDT 2017
:notice:fetch --->  Fetching distfiles for libnetpbm
:debug:fetch Executing org.macports.fetch (libnetpbm)
:debug:fetch Environment: 
:debug:fetch CC_PRINT_OPTIONS='YES'
:debug:fetch CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work/.CC_PRINT_OPTIONS'
:debug:fetch CPATH='/opt/local/include'
:debug:fetch LIBRARY_PATH='/opt/local/lib'
:debug:fetch MACOSX_DEPLOYMENT_TARGET='10.13'
:info:fetch Executing:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work" && /usr/bin/svn --non-interactive --trust-server-cert checkout https://svn.code.sf.net/p/netpbm/code/@3064 --non-recursive /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work 2>&1
:debug:fetch system:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work" && /usr/bin/svn --non-interactive --trust-server-cert checkout https://svn.code.sf.net/p/netpbm/code/@3064 --non-recursive /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work 2>&1
:info:fetch svn: E170013: Unable to connect to a repository at URL 'https://svn.code.sf.net/p/netpbm/code'
:info:fetch svn: E160013: '/p/netpbm/code' path not found
:info:fetch Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work" && /usr/bin/svn --non-interactive --trust-server-cert checkout https://svn.code.sf.net/p/netpbm/code/@3064 --non-recursive /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/work 2>&1
:info:fetch Exit code: 1
:error:fetch Failed to fetch libnetpbm: Subversion check out failed
:debug:fetch Error code: NONE
:debug:fetch Backtrace: Subversion check out failed
:debug:fetch     while executing
:debug:fetch "svnfetch"
:debug:fetch     (procedure "portfetch::fetch_main" line 13)
:debug:fetch     invoked from within
:debug:fetch "$procedure $targetname"
:error:fetch See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_netpbm/libnetpbm/main.log for details.

need to install octave on macOS 10.13 and this is a dependency.

Change History (4)

comment:1 Changed 3 years ago by gallafent

Cc: gallafent added

comment:2 in reply to:  description Changed 3 years ago by fazilz (Fazil Zuhaib)

seems to work now!

sudo port clean libnetpbm 
sudo port install libnetpbm

I think the tar files were just added to the repos.

Last edited 2 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #54918.

comment:4 Changed 2 years ago by ryandesign (Ryan Schmidt)

In 9192b329cc13ddda097b50a8cb086adc4b8d5435/macports-ports:

netpbm: Fetch from GitHub mirror instead of SourceForge svn

Fetching from svn has been repeatedly problematic.

See: #28250
See: #28590
See: #29692
See: #31987
See: #32000
See: #36517
See: #38823
See: #41023
See: #48687
See: #50087
See: #54428
See: #54918
See: #54919
See: #54924
See: #55853
See: #55930
See: #55986

Note: See TracTickets for help on using tickets.