Opened 2 months ago

Closed 2 months ago

#55025 closed defect (worksforme)

Bind9 on High Sierra interface en0 failed

Reported by: sdugoten Owned by: danielluke (Daniel J. Luke)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: bind9

Description (last modified by raimue (Rainer Müller))

After installing the newest macport bind9 @9.11.2 (net), I have having this problem a few time. I saw this in /var/log/system.log

07-Oct-2017 02:45:36.178 network: info: listening on IPv4 interface en0, 10.0.1.7#53
07-Oct-2017 02:45:36.178 network: error: could not listen on UDP socket: permission denied
07-Oct-2017 02:45:36.179 network: error: creating IPv4 interface en0 failed; interface ignored

After that happen, Bind is not answering any query. I have rolled back to bind9 @9.11.1-P3_0 and seems OK

Change History (3)

comment:1 Changed 2 months ago by Schamschula (Marius Schamschula)

  • Keywords bind9 removed
  • Owner set to danielluke
  • Status changed from new to assigned

Please add the maintainer to the CC field. For example, see port info --maintainer bind9

comment:2 Changed 2 months ago by raimue (Rainer Müller)

  • Description modified (diff)
  • Keywords interface en0 failed removed

Please use WikiFormatting.

comment:3 Changed 2 months ago by danielluke (Daniel J. Luke)

  • Resolution set to worksforme
  • Status changed from assigned to closed

bind9 works fine on my High Sierra box. I suspect you have something else (perhaps a previous version of bind9) bound to that IP/port.

Note: See TracTickets for help on using tickets.