Opened 2 months ago

Closed 2 months ago

#55033 closed defect (duplicate)

gcc5: add workable gcj functionality back

Reported by: kencu (Ken) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: nortcele, kencu (Ken), BYUMcKay
Port: gcc5

Description

It may be possible to add full gcj functionality back into gcc5, possibly coupled with an update to gcc 5.5.0. See 54949.

nortcele has done some work on this already, and this is to be explored further as part of an update to gcc5.

Attachments (2)

gcc5.5.diff (1.9 KB) - added by kencu (Ken) 2 months ago.
gcc5.5-java.diff (3.5 KB) - added by kencu (Ken) 2 months ago.

Download all attachments as: .zip

Change History (5)

Changed 2 months ago by kencu (Ken)

Changed 2 months ago by kencu (Ken)

comment:1 Changed 2 months ago by nortcele

Caution, these patches are adapted for the first gcc5.5 release candidate, a transitionnal version. The final version should appear soon and then informations specific to the release candidate won't be valid.

And the modifications for gcj where from Howarth in #49227.

Last edited 2 months ago by nortcele (previous) (diff)

comment:2 Changed 2 months ago by kencu (Ken)

I see. thanks. This ticket does seem like aduplicate of that one then. I read through that other ticket, and if those changes bring back gcj function to build pdftk, I'd be for them.

comment:3 Changed 2 months ago by kencu (Ken)

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.