Opened 3 years ago

Closed 3 years ago

#55079 closed defect (duplicate)

py27-cryptography @2.1.1 does not build on PPC Leopard, Mac OS X 10.5.8, because of invalid compiler switch: cc1: error: -Werror=sign-conversion: No option -Wsign-conversion

Reported by: ballapete (Peter Dyballa) Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: leopard Cc:
Port: py-cryptography

Description

building '_openssl' extension
creating build/temp.macosx-10.5-ppc-2.7/build
creating build/temp.macosx-10.5-ppc-2.7/build/temp.macosx-10.5-ppc-2.7
/usr/bin/gcc-4.2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -arch ppc -I/opt/local/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c build/temp.macosx-10.5-ppc-2.7/_openssl.c -o build/temp.macosx-10.5-ppc-2.7/build/temp.macosx-10.5-ppc-2.7/_openssl.o -Wconversion -Wno-error=sign-conversion
cc1: error: -Werror=sign-conversion: No option -Wsign-conversion
error: command '/usr/bin/gcc-4.2' failed with exit status 1
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_python_py-cryptography/py27-cryptography/work/cryptography-2.1.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 setup.py --no-user-cfg build 
Exit code: 1
Error: Failed to build py27-cryptography: command execution failed

Attachments (1)

main.log (30.9 KB) - added by ballapete (Peter Dyballa) 3 years ago.
Main.log from PPC Leopard

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by ballapete (Peter Dyballa)

Attachment: main.log added

Main.log from PPC Leopard

comment:1 Changed 3 years ago by ballapete (Peter Dyballa)

In this case cryptography-2.1.1/docs/faq.rst recommends tp use a more up-to-date compiler.

comment:2 Changed 3 years ago by ballapete (Peter Dyballa)

With s lot of warnings macports-gcc6 builds the package:

building '_openssl' extension
/opt/local/bin/gcc-mp-6 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -m32 -I/opt/local/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c build/temp.macosx-10.5-ppc-2.7/_openssl.c -o build/temp.macosx-10.5-ppc-2.7/build/temp.macosx-10.5-ppc-2.7/_openssl.o -Wconversion -Wno-error=sign-conversion
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function 'SSL_SESSION_get_master_key':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:2192:23: warning: conversion to 'size_t {aka long unsigned int}' from 'int' may change the sign of the result [-Wsign-conversion]
         return session->master_key_length;
                ~~~~~~~^~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:2194:18: warning: conversion to 'size_t {aka long unsigned int}' from 'int' may change the sign of the result [-Wsign-conversion]
         outlen = session->master_key_length;
                  ^~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_setup_ssl_threads':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:2608:28: warning: conversion to 'unsigned int' from 'int' may change the sign of the result [-Wsign-conversion]
         _ssl_locks_count = CRYPTO_num_locks();
                            ^~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function 'Cryptography_pem_password_cb':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:2641:35: warning: conversion to 'size_t {aka long unsigned int}' from 'int' may change the sign of the result [-Wsign-conversion]
         memcpy(buf, st->password, st->length);
                                   ^~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_add_extra_chain_cert':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:47696:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_add_extra_chain_cert(x0, x1);
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_add_extra_chain_cert':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:47736:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_add_extra_chain_cert(x0, x1); }
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_clear_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:47785:10: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_clear_options(x0, x1);
          ^~~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:47785:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_clear_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:47818:14: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_clear_options(x0, x1); }
              ^~~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:47818:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_get_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:48070:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_get_mode(x0);
          ^~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_get_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:48093:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_get_mode(x0); }
              ^~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_get_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:48106:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_get_options(x0);
          ^~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_get_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:48129:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_get_options(x0); }
              ^~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_get_session_cache_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:48142:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_get_session_cache_mode(x0);
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_get_session_cache_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:48165:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_get_session_cache_mode(x0); }
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_set_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49626:10: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_set_mode(x0, x1);
          ^~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49626:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_set_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49659:14: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_set_mode(x0, x1); }
              ^~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49659:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_set_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49790:10: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_set_options(x0, x1);
          ^~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49790:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_set_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49823:14: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_set_options(x0, x1); }
              ^~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49823:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
In file included from build/temp.macosx-10.5-ppc-2.7/_openssl.c:707:0:
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_set_session_cache_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49836:45: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_set_session_cache_mode(x0, x1);
                                             ^
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49836:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_set_session_cache_mode(x0, x1);
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from build/temp.macosx-10.5-ppc-2.7/_openssl.c:707:0:
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_set_session_cache_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49869:49: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_set_session_cache_mode(x0, x1); }
                                                 ^
build/temp.macosx-10.5-ppc-2.7/_openssl.c:49869:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_set_session_cache_mode(x0, x1); }
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_set_tmp_dh':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:50185:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_set_tmp_dh(x0, x1);
          ^~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_set_tmp_dh':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:50225:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_set_tmp_dh(x0, x1); }
              ^~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_CTX_set_tmp_ecdh':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:50238:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_CTX_set_tmp_ecdh(x0, x1);
          ^~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_CTX_set_tmp_ecdh':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:50278:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_CTX_set_tmp_ecdh(x0, x1); }
              ^~~~~~~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_get_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:52082:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_get_mode(x0);
          ^~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_get_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:52105:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_get_mode(x0); }
              ^~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_get_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:52118:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   return SSL_get_options(x0);
          ^~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_get_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:52141:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_get_options(x0); }
              ^~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_set_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:53806:10: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   return SSL_set_mode(x0, x1);
          ^~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:53806:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_set_mode':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:53839:14: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_set_mode(x0, x1); }
              ^~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:53839:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_d_SSL_set_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:53852:10: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   return SSL_set_options(x0, x1);
          ^~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:53852:10: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]
build/temp.macosx-10.5-ppc-2.7/_openssl.c: In function '_cffi_f_SSL_set_options':
build/temp.macosx-10.5-ppc-2.7/_openssl.c:53885:14: warning: conversion to 'long int' from 'long unsigned int' may change the sign of the result [-Wsign-conversion]
   { result = SSL_set_options(x0, x1); }
              ^~~~~~~~~~~~~~~
build/temp.macosx-10.5-ppc-2.7/_openssl.c:53885:14: warning: conversion to 'long unsigned int' from 'long int' may change the sign of the result [-Wsign-conversion]

comment:3 Changed 3 years ago by mf2k (Frank Schima)

Cc: stromnov@… removed
Owner: set to stromnov
Port: py-cryptography added; py27-cryptography removed
Status: newassigned

comment:4 Changed 3 years ago by ballapete (Peter Dyballa)

Version 2.1.2 just built successfully on PPC Leopard. GCC 4.2 was used for compilation.

comment:5 in reply to:  3 Changed 3 years ago by jsalort (Julien Salort)

I have the same error message on Intel with Mac OS X 10.6 Snow Leopard. It is not a PPC specific issue. It works when gcc6 is chosen manually (and after manually downloading the distfiles with macports' wget):

sudo port install py27-cryptography configure.compiler=macports-gcc-6

comment:6 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #54519.

Note: See TracTickets for help on using tickets.