Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#55236 closed defect (fixed)

After starting mutt (neomutt @20171027) I get "Segmentation fault: 11" or "Abort trap: 6"

Reported by: mimaoffice (Michele Marcionelli) Owned by: lbschenkel (Leonardo Brondani Schenkel)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc: l2dy (Zero King)
Port: neomutt

Description

Just installed as "root" MacPort on OS X 10.12.6 from scratch as follow:

PREFIX=/opt/local2
export PATH=$PREFIX/bin:$PATH
V=2.4.2

cd /tmp/
curl -O http://distfiles.macports.org/MacPorts/MacPorts-$V.tar.bz2
tar jxf MacPorts-$V.tar.bz2
cd MacPorts-$V
chown -R 0:0 .

./configure --prefix=$PREFIX
make
make install

and afterward I installed "neomutt" as follow:

port install neomutt

I have now this version of neomutt installed:

port installed neomutt
==>
neomutt @20171027_0+idn+mutt (active)

Now, connecting to some server results in a "Segmentation fault: 11" and to other server in an "Abort trap: 6". I cannot user mutt anymore. The last good version that I can still use is @20170912.

I tested with these minimal configurations:

1) the "Segmentation fault: 11"-version

set imap_user="******"
set imap_pass="******"
set folder="{mail.ethz.ch/ssl}"
set spoolfile="{mail.ethz.ch/ssl}INBOX"

2) the "Abort trap: 6"-version:

set imap_user="******"
set imap_pass="******"
set folder="{imap.mail.hostpoint.ch/ssl}"
set spoolfile="{imap.mail.hostpoint.ch/ssl}INBOX"

the full error message is

mutt(85451,0x7fffc69923c0) malloc: *** error for object 0x1064a80cb: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

Can somebody help me?

Bests, Michele

Attachments (2)

neomutt_2017-11-03-223557_fibonacci.crash (11.1 KB) - added by mimaoffice (Michele Marcionelli) 4 years ago.
neomutt_2017-11-03-223559_fibonacci.crash (11.2 KB) - added by mimaoffice (Michele Marcionelli) 4 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 4 years ago by Schamschula (Marius Schamschula)

Cc: l2dy added
Owner: set to lbschenkel
Priority: HighNormal
Status: newassigned

Please don't set the priority. That field is for MacPorts maintainers.

Please add the maintainers to the CC field. In this case use port info --maintainers neomutt.

comment:2 Changed 4 years ago by mimaoffice (Michele Marcionelli)

Cc: mimaoffice added

comment:3 Changed 4 years ago by mimaoffice (Michele Marcionelli)

Cc: mimaoffice removed

comment:4 Changed 4 years ago by mf2k (Frank Schima)

Keywords: neomutt sierra segfault abort removed

comment:5 Changed 4 years ago by ryandesign (Ryan Schmidt)

Could you attach the crash logs, please?

comment:6 in reply to:  5 Changed 4 years ago by mimaoffice (Michele Marcionelli)

Replying to ryandesign:

Could you attach the crash logs, please?

How can I do that? Usually I would install neomutt with the variant debug which seems to be disappeared:

https://github.com/macports/macports-ports/blob/master/mail/neomutt/Portfile

By the way: the Portfile here above corresponds now (as of 3 Nov 2017 @ 22:00) to the version 20171027, but the info on this page corresponds to the older version 20170912:

https://www.macports.org/ports.php?by=name&substr=neomutt

If I anyway try to install neomutt with the variant debug and I start mutt with the option -d2 I get the expected error message

DEBUG was not defined during compilation. -d Ignored.

Any Idea?

Bests, Michele

comment:7 Changed 4 years ago by kencu (Ken)

First hit on Google:

Locating crash logs under OS X 10.7 and later.

Under OS X 10.7 ("Lion"), and later, crash logs are stored in the folder ~/Library/Logs/DiagnosticReports/. You can reach this folder by following these steps:

    In Finder, click on the Go menu and choose Go to Folder... After selecting this command, a text field should appear in Finder.

    Paste the path ~/Library/Logs/DiagnosticReports/ into the text field.

    Click the Go button.

comment:8 Changed 4 years ago by mimaoffice (Michele Marcionelli)

Thank you Ken!!

Ok I found out when I get the Segmentation fault: 11 and when then Abort trap: 6... but still it is strange:

/opt/local2/bin/mutt -F muttrc-test1
==>
Segmentation fault: 11

and

/opt/local2/bin/mutt -F ~/muttrc-test1
==>
mutt(60684,0x7fffc69923c0) malloc: *** error for object 0x7fffbdaaa610: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

Attached see the crash logs for both tests.

Changed 4 years ago by mimaoffice (Michele Marcionelli)

Changed 4 years ago by mimaoffice (Michele Marcionelli)

comment:9 Changed 4 years ago by lbschenkel (Leonardo Brondani Schenkel)

This may be beyond my skills to troubleshoot/fix, it looks like I should report this upstream.

comment:10 in reply to:  9 Changed 4 years ago by mimaoffice (Michele Marcionelli)

Replying to lbschenkel:

This may be beyond my skills to troubleshoot/fix, it looks like I should report this upstream.

Ok... but can you replicate the problem?

comment:11 Changed 4 years ago by lbschenkel (Leonardo Brondani Schenkel)

No, I cannot. Obviously I cannot use your exact config file, but an equivalent version using my IMAP server works for me.

comment:12 Changed 4 years ago by mimaoffice (Michele Marcionelli)

What if you use my config file with some dummy entries for username and password? You should get a Login failed and not a Abort trap: 6.

comment:13 Changed 4 years ago by lbschenkel (Leonardo Brondani Schenkel)

I will try.

In the meantime, I have reported your issue to upstream: https://github.com/neomutt/neomutt/issues/910

Because in case it's a genuine problem, it is unlikely I can fix it downstream.

comment:14 Changed 4 years ago by mimaoffice (Michele Marcionelli)

Está bem, obrigado!! ;-) Michele

comment:15 Changed 4 years ago by lbschenkel (Leonardo Brondani Schenkel)

Actually I can reproduce it, using your files exactly as posted with the asterisks...

comment:16 Changed 4 years ago by lbschenkel (Leonardo Brondani Schenkel)

Resolution: fixed
Status: assignedclosed

In 7173c17c875bfe356732f468fbab2b054cfddd3e/macports-ports:

neomutt: fix crash when parsing config file

Upstream crashes when parsing certain config files, as reported in:
#55236

Bug was reported in: https://github.com/neomutt/neomutt/issues/910,
a fix was introduced in: https://github.com/neomutt/neomutt/pull/911

I have tested the above fix and it fixes the crash, so I'm incorporating
the patch for now. Next upstream release should have the fix.

Fixes: #55236

comment:17 Changed 4 years ago by lbschenkel (Leonardo Brondani Schenkel)

Michelle: upstream has acknowledged the issue, and there is a fix. I have tested the fix and confirmed that it solves the crash. I incorporated the patch and bumped the revision number.

comment:18 Changed 4 years ago by mimaoffice (Michele Marcionelli)

Thank you Leonardo!! How can I install the new revision? I tried with

port selfupdate
port upgrade outdated

... but not upgrade for neomutt has been installed/found.

comment:19 Changed 4 years ago by lbschenkel (Leonardo Brondani Schenkel)

It takes a while for changes made to the repository to propagate to the tarball (and the mirrors). Try again in a few hours.

Note: See TracTickets for help on using tickets.