Opened 4 years ago

Closed 4 years ago

#55256 closed defect (duplicate)

qt5-qtbase: no longer distributable

Reported by: mojca (Mojca Miklavec) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: qt5-qtbase

Description (last modified by mojca (Mojca Miklavec))

The qt5-qtbase version 5.9.2_1 is available on the server as a binary, but since yesterday's update the buildbot says:

"qt5-qtbase" is not distributable because its dependency "xattr" has license "unknown" which is not known to be distributable

For such a massive package it would be nice to resolve the problem.

This also raises an unrelated question: what happens to distributability of existing packages (or lack of them) when a licence of a dependency changes or when a dependency changes its own dependencies?

Change History (4)

comment:1 Changed 4 years ago by mojca (Mojca Miklavec)

Description: modified (diff)

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Cc: ryandesign added
Owner: changed from MarcusCalhoun-Lopez, ryandesign to MarcusCalhoun-Lopez
Status: newassigned

My understanding is that Trac only allows a single person to be the ticket owner.

comment:3 Changed 4 years ago by mojca (Mojca Miklavec)

I'm sorry. I sometimes keep mixing the owner and the CC field. I CC-ed Ryan mostly because of the last paragraph.

comment:4 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #55246.

Note: See TracTickets for help on using tickets.