Opened 3 years ago

Closed 3 years ago

#55346 closed update (fixed)

LASzip @2.2.0: update to 3.1.1

Reported by: l2dy (Zero King) Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: LASzip

Description

It compiles, but...

$ otool -D /opt/local/lib/liblaszip.dylib
/opt/local/lib/liblaszip.dylib:
@executable_path/../lib/liblaszip.3.dylib
$ otool -D /opt/local/lib/liblaszip_api.dylib
/opt/local/lib/liblaszip_api.dylib:
@executable_path/../lib/liblaszip_api.3.dylib

Attachments (3)

0001-LASzip-update-to-3.1.1.patch (1.7 KB) - added by l2dy (Zero King) 3 years ago.
LASzip-3.1.1.diff (1.6 KB) - added by ryandesign (Ryan Schmidt) 3 years ago.
install_name.patch (583 bytes) - added by ryandesign (Ryan Schmidt) 3 years ago.

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by l2dy (Zero King)

comment:1 Changed 3 years ago by l2dy (Zero King)

Keywords: haspatch added

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

That's easy enough to fix. I'm more concerned that the library version has decreased from 6 (in version 2.2.0) to 3 (in 3.1.1).

The two programs, laszip-config and laszippertest, are also no longer included in 3.1.1. They're in the examples directory now, but not installed anymore. Not sure if we should try to install them.

Changed 3 years ago by ryandesign (Ryan Schmidt)

Attachment: LASzip-3.1.1.diff added

Changed 3 years ago by ryandesign (Ryan Schmidt)

Attachment: install_name.patch added

comment:3 in reply to:  2 Changed 3 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign:

I'm more concerned that the library version has decreased from 6 (in version 2.2.0) to 3 (in 3.1.1).

I've brought this to the attention of the developer.

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Owner: set to Veence
Status: newassigned

laszip was updated to 3.2.0 in [e3710d6800e803ebaa9528d3bdb38fb2fcade513/macports-ports], without fixing the library version problem or the install_name problem. When either or both of these problems are fixed, the ports that link with the laszip library need to be rebuilt by increasing their revisions.

comment:5 Changed 3 years ago by Veence (Vincent)

I’ve committed a fix to the wrong library ID problem, and revbump'ed saga and pdal which depend on it. I’ve no idea what to do for the version mishandling, though.

Last edited 3 years ago by Veence (Vincent) (previous) (diff)

comment:6 Changed 3 years ago by ryandesign (Ryan Schmidt)

laszip 3.2.1 has been released which should fix the library version, setting it to 8. However, the laszip 3.2.1 release files are named wrong, with version number 3.2.0 instead of 3.2.1; let's wait and see if upstream will fix that before we update.

comment:8 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

In 38e38a224771849284e79305b037fb01678f1446/macports-ports:

laszip: Update to 3.2.2

Add a patch to prevent the build system from overriding the install_name
set by the cmake 1.1 portgroup.

Closes: #55346
Closes: #56142

Note: See TracTickets for help on using tickets.