Opened 6 days ago

Closed 6 days ago

Last modified 6 days ago

#55476 closed defect (invalid)

openmpi-gcc7 @1.10.3: installs version 3.0.0 instead

Reported by: mccoys Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc: sean@…
Port: openmpi

Description (last modified by mf2k (Frank Schima))

Hi

I am trying to install two versions of openmpi. I already have @3.0.0 installed, but it seems to be somewhat incompatible to hdf5. For debugging reasons, I tried to install openmpi 1.10 using the following command:

sudo port install openmpi-gcc7 @1.10 +threads

It shows no error and installs properly, but it installs the wrong version, 3.0.0, which is already installed. In fact it does not build anything: it only scans for errors and proceeds.

I expect that -gcc7 and +threads are not relevant to this ticket.

Thanks

Change History (4)

comment:1 Changed 6 days ago by mf2k (Frank Schima)

In the future, please use WikiFormatting.

comment:2 Changed 6 days ago by mf2k (Frank Schima)

  • Description modified (diff)

comment:3 Changed 6 days ago by mf2k (Frank Schima)

  • Resolution set to invalid
  • Status changed from new to closed

You have a misunderstanding about the port command. Using @1.10 is not valid. There is no way to request an arbitrary version of a port.

comment:4 Changed 6 days ago by mf2k (Frank Schima)

You can read about a manual workaround here: wiki:howto/InstallingOlderPort

Note: See TracTickets for help on using tickets.