Opened 12 months ago

Last modified 11 months ago

#55496 assigned defect

valgrind @3.13.0 is not compatible with macOS version 10.13

Reported by: lucbouge (Luc Bougé) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version:
Keywords: highsierra Cc: majoc-at-astro (majoc-at-astro)
Port: valgrind

Description

Valgrind fails to install on MacOs 10.13.2 High Sierra.

$ sw_vers
ProductName:	Mac OS X
ProductVersion:	10.13.2
BuildVersion:	17C88

$ port list valgrind
valgrind                       @3.13.0         devel/valgrind

$ sudo port install valgrind
...
Error: valgrind @3.13.0 is only compatible with macOS versions from 10.5 up to 10.12.
...

Change History (6)

comment:1 Changed 12 months ago by ryandesign (Ryan Schmidt)

Keywords: highsierra added
Owner: set to raimue
Port: valgrind added
Status: newassigned
Summary: Valgrind @3.13.0 is not compatible with macOS version 10.13valgrind @3.13.0 is not compatible with macOS version 10.13

There's not really much more to say. The error message is correct.

comment:2 Changed 12 months ago by lucbouge (Luc Bougé)

Thanks, Ryan.

Valgrind is so useful to me, and probably for many of us, too. Is there a plan to set up a version compatible with 10.13?

Best regards,

Luc.

comment:3 Changed 12 months ago by ryandesign (Ryan Schmidt)

I am not aware of the existence of a version of valgrind that is compatible with 10.13. If you want such a thing to exist, please talk to the developers of valgrind.

comment:4 Changed 12 months ago by majoc-at-astro (majoc-at-astro)

Cc: majoc-at-astro added

comment:5 Changed 11 months ago by majoc-at-astro (majoc-at-astro)

Another possibility (fwiw):

$ port installed | grep valgrind
  openmpi-gcc6 @3.0.0_0+fortran+threads+valgrind (active)
  valgrind-devel @3.14.0-r2017-11-21_0+gcc6+openmpi (active)

comment:6 Changed 11 months ago by lucbouge (Luc Bougé)

Thanks a lot for your hint. Let me try it at once.

Actually, the message for Package valgrind has been updated at some point but I did not notice it until now.

Best regards,

Luc.

$ sudo port install valgrind
[...]
Error: valgrind @3.13.0 is only compatible with macOS versions from 10.5 up and Xcode8 or less.
Error: Please install valgrind-devel to work with Xcode9 until version 3.14 is released.
$ sw_vers
ProductName:	Mac OS X
ProductVersion:	10.13.2
BuildVersion:	17C88
Note: See TracTickets for help on using tickets.