Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#55534 closed defect (duplicate)

valgrind: failed check for a supported compiler on macOS Sierra (Version 10.12.6)

Reported by: ierofant (Андрей Корнилов) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: valgrind

Description

Configuration for valgrind fails on macOS Sierra (Version 10.12.6)

Xcode 9.2 Build version 9C40b
Apple LLVM version 9.0.0 (clang-900.0.39.2)

configure:5362: result: gcc3
configure:5381: checking for diff -u
configure:5389: result: yes
configure:5401: checking for a supported version of gcc
configure:5485: result: no (applellvm-9.0.0)
configure:5487: error: please use gcc >= 3.0 or clang >= 2.9 or icc >= 13.0

Attachments (2)

config.log (22.8 KB) - added by ierofant (Андрей Корнилов) 3 years ago.
main.log (53.5 KB) - added by ierofant (Андрей Корнилов) 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by ierofant (Андрей Корнилов)

Attachment: config.log added

Changed 3 years ago by ierofant (Андрей Корнилов)

Attachment: main.log added

comment:1 Changed 3 years ago by kencu (Ken)

see also 55496.

This looks to be essentially a duplicate of that ticket, but it looks like the error is not so much 10.12 or 10.13 but Xcode 9.x.

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #55425.

comment:3 Changed 3 years ago by kencu (Ken)

Note: See TracTickets for help on using tickets.