Opened 3 years ago

Closed 3 years ago

#55561 closed defect (duplicate)

osxfuse @3.7.1: fails to compile, libclang.dylib not been found

Reported by: porchy13 Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: osxfuse

Description

After installing lbzip2 (see ticket 55560), osxfuse always fails to compile on macOS High Sierra. This time, the cause is libclang.dylib which has not been founded. During the compilation process, libclang.dylib is searched in various paths but none corresponding to the real location, which is /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib.

Attachments (1)

main.log (3.6 MB) - added by porchy13 3 years ago.
log of the compilation process

Change History (2)

Changed 3 years ago by porchy13

Attachment: main.log added

log of the compilation process

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Keywords: osxfuse libclang removed
Resolution: duplicate
Status: newclosed
Summary: osxfuse @3.7.1 : fails to compile, libclang.dylib not been foundosxfuse @3.7.1: fails to compile, libclang.dylib not been found

Duplicate of #54939.

Note: See TracTickets for help on using tickets.