Opened 3 years ago

Last modified 3 years ago

#55652 assigned defect

Cannot destroot libtool 2.4.6_4

Reported by: M-Rick Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: libtool

Description (last modified by mf2k (Frank Schima))

Failed to destroot libtool: command execution failed

:info:destroot xinstall: TODO -> /private/opt/usr/var/macports/build/_private_opt_usr_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libtool/libtool/work/destroot/opt/usr/share/doc/libtool/TODO
:debug:destroot system: xattr -r -d com.dropbox.attributes /private/opt/usr/var/macports/build/_private_opt_usr_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libtool/libtool/work/destroot
:info:destroot Traceback (most recent call last):
:info:destroot   File "/usr/bin/xattr-2.7", line 7, in <module>
:info:destroot     from pkg_resources import load_entry_point
:info:destroot ImportError: No module named pkg_resources
:info:destroot Command failed: xattr -r -d com.dropbox.attributes /private/opt/usr/var/macports/build/_private_opt_usr_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libtool/libtool/work/destroot
:info:destroot Exit code: 1
:error:destroot Failed to destroot libtool: command execution failed
:debug:destroot Error code: NONE
:debug:destroot Backtrace: command execution failed
:debug:destroot     while executing
:debug:destroot "$post $targetname"
:error:destroot See /opt/usr/var/macports/logs/_private_opt_usr_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libtool/libtool/main.log for details.

Attachments (2)

main.log (71.9 KB) - added by mf2k (Frank Schima) 3 years ago.
libtool main.log (72.7 KB) - added by M-Rick 3 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Cc: larryv removed
Owner: set to larryv
Status: newassigned

In the future, please attach the main.log file instead of pasting the entire contents into the description.

Changed 3 years ago by mf2k (Frank Schima)

Attachment: main.log added

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 3 years ago by kencu (Ken)

We saw this error when a user had installed his own version of python in a non-MacPorts fashion. It confused python and it couldn't find system-installed resources any longer. I can't find the ticket where we worked through this right now -- perhaps it was on the mailing list? It was within the last few months, after libtool was changed to strip out these attributes using xattr.

The failing command is here:

xattr -r -d com.dropbox.attributes /private/opt/usr/var/macports/build/_private_opt_usr_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libtool/libtool/work/destroot

try running the command manually, using sudo. I think that was where we got some more clues about the issue.

Do you have a manually-installed python somewhere, outside of MacPorts?

comment:4 Changed 3 years ago by M-Rick

Yes I do have another Python versions in /Library/Python .

comment:5 Changed 3 years ago by kencu (Ken)

OK. if the xattr system command won't work due to that extra Python installation, your options would be to uninstall the extra python versions and get xattr working again, or just comment out the xattr command in the Portfile. It's not essential.

comment:6 Changed 3 years ago by ryandesign (Ryan Schmidt)

I'm also curious why you chose the unusual MacPorts prefix "/opt/usr". Using a prefix other than our default "/opt/local" means you cannot receive our precompiled port binaries.

I also think from your log that /opt is actually a symlink to /private/opt. If that's so, it may be a leftover artifact from an ancient version of Cisco VPN; see this entry in an ancient version of our FAQ.

comment:7 Changed 3 years ago by M-Rick

Well, I removed my Python installation, and everything, downloaded the Sierras’s package. It worked and it was the only port I installed in it.

But whenever I changed to use an esoteric path, proceeding the same way, libtool won't destroot. I tried with a laptop I mostly use to make presentations outside, I installed developper tools to make it possible, same result. I never had trouble with previous macOS versions with 10.11 and under, whatever the Pythons versions I had installed or the paths I was using to install Macports. I have been using esoteric paths for almost 10 years without troubles. Then I did an install in an esoteric path under an old Mac running macOS 10.7. It did worked perfectly as usual. This seems to have appeared in latest builds of libtools and Sierra.

Does xattr -r -d com.dropbox.attributes is necessary? It doesn't have the attributes to connect to my DropBox accounts.

OS Python version

Python 2.7.13 (v2.7.13:a06454b1afa1, Dec 17 2016, 12:39:47) 
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
{{{
}}}
Last edited 3 years ago by M-Rick (previous) (diff)

Changed 3 years ago by M-Rick

Attachment: libtool main.log added

comment:8 in reply to:  5 Changed 3 years ago by kencu (Ken)

Replying to kencu:

or just comment out the xattr command in the Portfile. It's not essential.

It's not essential. If you can't fix your xattr command, or have run out of patience trying to figure out why it is broken, just comment the xattr command out in the portfile.

You find the portfile with `port file libtool`. Edit out that command with your favourite text editor.

Last edited 3 years ago by kencu (Ken) (previous) (diff)

comment:9 Changed 3 years ago by M-Rick

Thank you, editing the libtool portfile did the work.

Note: See TracTickets for help on using tickets.