Opened 14 years ago

Closed 13 years ago

Last modified 10 years ago

#5574 closed defect (duplicate)

BUG: libiconv won't install

Reported by: bxf4@… Owned by: mij@…
Priority: High Milestone:
Component: ports Version:
Keywords: Cc:
Port:

Description

libiconv is a dependency for a couple things I've tried to install, but it won't install cleanly. I built it without a problem using 'port -d build libiconv', but when I try to install it, I get the following:

d-128-95-226-189:~ bxf4$ sudo port install libiconv Password: ---> Staging libiconv into destroot Error: Target com.apple.destroot returned: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/libiconv-1.10" && make install DESTDIR=/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot" returned error 2 Command output: libtool: install: warning: remember to run `libtool --finish /opt/local/lib' if test -n ""; then /usr/bin/install -c -m 644 /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local/lib/.new && mv /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local/lib/.new /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local/lib/ ; fi cd srclib && make install prefix='/opt/local' exec_prefix='/opt/local' libdir='/opt/local/lib' make[2]: Nothing to be done for `am--refresh'. make install-am make[3]: Nothing to be done for `am--refresh'. make[4]: Nothing to be done for `am--refresh'. make[3]: Nothing to be done for `install-exec-am'. make[3]: Nothing to be done for `install-data-am'. cd src && make install prefix='/opt/local' exec_prefix='/opt/local' libdir='/opt/local/lib'

test ls -ld . | sed -e 's/^d\(.........\).*/\1/' = rwxrwxrwx
chmod 777 .

if [ ! -d /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local ] ; then /bin/sh ../build-aux/mkinstalldirs /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local ; fi if [ ! -d /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local ] ; then /bin/sh ../build-aux/mkinstalldirs /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local ; fi if [ ! -d /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local/bin ] ; then /bin/sh ../build-aux/mkinstalldirs /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local/bin ; fi case "darwin8.2.0" in \

hpux*) gcc if test -n ''; then /opt/local/bin; fi iconv.o

../srclib/libicrt.a -L/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local/lib -liconv -L/opt/local/lib -lintl -liconv -lc `if test -n '/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot'; then echo " -Wl,+b -Wl,/opt/local/lib"; fi` -o iconv;; \

*) /bin/sh ../libtool --mode=link gcc `if test -n ; then /opt/local/bin;

fi` iconv.o ../srclib/libicrt.a /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libiconv/work/destroot/opt/local/lib/libiconv.la -L/opt/local/lib -lintl -L/opt/local/lib -liconv -lc -R/opt/local/lib -o iconv;; \ esac gcc iconv.o -o iconv ../srclib/libicrt.a -L/opt/local/lib /opt/local/lib/libintl.dylib /opt/local/lib/libiconv.dylib -lc /usr/bin/ld: warning multiple definitions of symbol _locale_charset /opt/local/lib/libiconv.dylib(localcharset.o) definition of _locale_charset /opt/local/lib/libintl.dylib(localcharset.o) definition of _locale_charset /usr/bin/ld: warning suggest use of -bind_at_load, as lazy binding may result in errors or different symbols being used /usr/bin/ld: warning prebinding disabled because of undefined symbols /usr/bin/ld: Undefined symbols: _iconv_canonicalize symbol _locale_charset used from dynamic library /opt/local/lib/libiconv.dylib(localcharset.o) not from earlier dynamic library /opt/local/lib/libintl.3.dylib(localcharset.o) collect2: ld returned 1 exit status make[1]: * [install] Error 1 make: * [install] Error 2

I just started using Darwinports, so if I'm doing something incorrectly, please let me know. Thank you for your time and assistance.

Brian

Change History (5)

comment:1 Changed 14 years ago by mww@…

Owner: changed from darwinports-bugs@… to mij@…
Summary: libiconv won't installBUG: libiconv won't install

comment:2 Changed 14 years ago by bxf4@…

Well, I looked into this more tonight and I removed old versions libiconv.dylib and libintl.dylib from /opt/local/lib. (I think I must have had them from downloading gnupg from tiger packages.) Then I was able to install libiconv. Perhaps it was linking to an old version of the library, rather than the one being built at the time? Perhaps there's a way to get the build to look at the current dylibs first, rather than looking at the libraries on the system first?

comment:3 Changed 13 years ago by olegb@…

Resolution: duplicate
Status: newclosed

the same situation here: 5534

* This bug has been marked as a duplicate of 5534 *

comment:4 Changed 12 years ago by nox@…

Milestone: Port Bugs
Priority: BlockerHigh
Version: 1.0

comment:5 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.