Opened 3 years ago

Closed 3 years ago

#55740 closed defect (duplicate)

startupitem / launchd plist / port load instructions are not printed when installing from a binary archive

Reported by: ryandesign (Ryan Schmidt) Owned by:
Priority: Normal Milestone:
Component: base Version: 2.4.2
Keywords: Cc: ctreleaven (Craig Treleaven)
Port:

Description

If I install a port from a binary archive, instructions for how to load the launchd plist are not printed:

$ port -b install baloo -universal
--->  Computing dependencies for baloo
--->  Fetching archive for baloo
--->  Attempting to fetch baloo-4.14.3_3.darwin_16.x86_64.tbz2 from https://packages.macports.org/baloo
--->  Attempting to fetch baloo-4.14.3_3.darwin_16.x86_64.tbz2.rmd160 from https://packages.macports.org/baloo
--->  Installing baloo @4.14.3_3
--->  Activating baloo @4.14.3_3
--->  Cleaning baloo
--->  Some of the ports you installed have notes:
  baloo has the following notes:
    Don't forget that dbus needs to be started as the local user (not with sudo) before any KDE programs will launch.
    To start it run the following command:
     launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist

Compare this to what's printed when I build from source:

$ port -s install baloo
--->  Computing dependencies for baloo
--->  Fetching distfiles for baloo
--->  Attempting to fetch baloo-4.14.3.tar.xz from https://distfiles.macports.org/baloo
--->  Verifying checksums for baloo
--->  Extracting baloo
--->  Applying patches to baloo
--->  Configuring baloo
--->  Building baloo
--->  Staging baloo into destroot
--->  Creating launchd control script
###########################################################
# A startup item has been generated that will aid in
# starting baloo with launchd. It is disabled
# by default. Execute the following command to start it,
# and to cause it to launch at startup:
#
# sudo port load baloo
###########################################################
--->  Installing baloo @4.14.3_3
--->  Activating baloo @4.14.3_3
--->  Cleaning baloo
--->  Some of the ports you installed have notes:
  baloo has the following notes:
    Don't forget that dbus needs to be started as the local user (not with sudo) before any KDE programs will launch.
    To start it run the following command:
     launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist

Change History (4)

comment:1 Changed 3 years ago by ctreleaven (Craig Treleaven)

Cc: ctreleaven added

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Duplicate of #31798.

comment:3 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.