Opened 3 years ago

Closed 3 years ago

#55875 closed defect (fixed)

octave-control @3.0.0: ld: library not found for -lgfortran

Reported by: ATL-Flaneur (Andreas Yankopolus) Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: octave-control

Description

Building octave-control fails with a qt5-qtbase mismatch. The port octave-control is evidently looking for qt59-qtbase while qt5-qtbase is installed.

Running port installed on my system gives the following for qt5-qtbase:

qt5-qtbase @5.10.0_0+openssl (active)

Attachments (1)

main.log (86.8 KB) - added by ATL-Flaneur (Andreas Yankopolus) 3 years ago.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by ATL-Flaneur (Andreas Yankopolus)

Attachment: main.log added

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Keywords: octave-control qt5-base removed
Owner: set to Schamschula
Status: newassigned

In the future, please Cc the port maintainers (port info --maintainers octave-control), if any.

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

Summary: Build failure for octave-controloctave-control @3.0.0: ld: library not found for -lgfortran

I do not believe that the qt59 error message is relevant. It might be another symptom of the erroneous error message display discussed in #55560.

Rather, the real error seems to be:

:info:configure ld: warning: directory not found for option '-L/opt/local/lib/gcc7/gcc/x86_64-apple-darwin17/7.2.0'
:info:configure ld: warning: directory not found for option '-L/opt/local/lib/gcc7/gcc/x86_64-apple-darwin17/7.2.0/../../..'
:info:configure ld: library not found for -lgfortran
:info:configure clang: error: linker command failed with exit code 1 (use -v to see invocation)

comment:3 Changed 3 years ago by ATL-Flaneur (Andreas Yankopolus)

Regarding:

:info:configure ld: warning: directory not found for option '-L/opt/local/lib/gcc7/gcc/x86_64-apple-darwin17/7.2.0'

I have a 7.3.0 directory on my system but not 7.2.0. I created 7.2.0 as a symlink to 7.3.0, and the install went fine.

comment:4 Changed 3 years ago by Schamschula (Marius Schamschula)

Sorry not to get back on this any sooner. I was on travel w/o my GitHub passwd.

As octave-control uses the compilers PortGroup and builds against several versions of gcc, I hesitate to bump the revision for each new dot version of gcc.

comment:5 Changed 3 years ago by Schamschula (Marius Schamschula)

Well: a rev bump for octave-control was pointless

The problem is octave itself.

comment:6 Changed 3 years ago by Schamschula (Marius Schamschula)

Resolution: fixed
Status: assignedclosed

In 133a8ed0a0e2f574f80e018874b8bbe06169f095/macports-ports:

octave: revision bump for gcc7 7.3.0

Closes: #55875

Note: See TracTickets for help on using tickets.