Opened 2 years ago

Closed 2 years ago

#56018 closed defect (fixed)

Backport bugfixes to release-2.4 for next release

Reported by: neverpanic (Clemens Lang) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone: MacPorts 2.4.3
Component: base Version:
Keywords: Cc: neverpanic (Clemens Lang)
Port:

Description (last modified by neverpanic (Clemens Lang))

Ryan mentioned a number of changes that should be backported to release-2.4 for the next bugfix release.

Reinplace quietly when clearing dependency_libs in .la files https://github.com/macports/macports-base/commit/49a0c6f5a6088b4f7ecd0137b18d10a56f30694d

Fix case-only renames with no arguments https://github.com/macports/macports-base/commit/acc1e62d8560609652977e563734f805c41244cf

Fix incorrect portindex usage message https://github.com/macports/macports-base/commit/1c7c8b21c42962e9761aeb97844aa91f320eee47

Remove clang-3.8 from compiler fallback list on El Capitan and older https://github.com/macports/macports-base/commit/c4107fcd483646853321027af2e123aa0e70a1ce

Fix error when sw_vers fails https://github.com/macports/macports-base/commit/adf078d0e0626b831463dea740bfe4f008142cda

Fix typos in manpages https://github.com/macports/macports-base/commit/38fe236f3f830a79c39e50526a20a32b2345d6dc

Update macOS version checks https://github.com/macports/macports-base/commit/3ba09e0620be7a8e77e1b84da03309b09d98e902

Update Xcode version checks https://github.com/macports/macports-base/commit/5f6bd08834d4f6cab011e068f192b965993edc30

Error when port opened with nonexistent subport https://github.com/macports/macports-base/commit/9c48520c7347a84af603ed35ed27a96a42d57838

Fix leaving orphaned Portfiles in registry https://github.com/macports/macports-base/commit/6c8c70b370753b9015400b27afdcd303b7a0cb63

Ignore case in livecheck regexps https://github.com/macports/macports-base/commit/0310feb5f4c3858e067e3500936f6fa099c78803

Fix typo in warning message https://github.com/macports/macports-base/commit/677dda56cbf3fc310b96a2fc1b54ee7c85ce5375

Add /dev/{u,}random to sandbox https://github.com/macports/macports-base/commit/c8c1565f42a60c2b9e85a204603a66052f444c43

sandbox: Allow file-write-data for /var/db/mds https://github.com/macports/macports-base/commit/1f76522228abba0d8383071b059daff726a8c9f6

Close the portfiles after reading https://github.com/macports/macports-base/commit/c2df3cc958635f7ac6d0983288723c6ea097b221

Trace mode broken on High Sierra #55575

Go through this list and backport all relevant changes. Do not forget to update the milestone field of any tickets associated with these changes to MacPorts 2.4.3.

Change History (10)

comment:1 Changed 2 years ago by neverpanic (Clemens Lang)

Description: modified (diff)

comment:2 Changed 2 years ago by raimue (Rainer Müller)

I went through the list and will push the backported changes to release-2.4.

These did not apply for the reasons given:

Fix typo in warning message ​https://github.com/macports/macports-base/commit/677dda56cbf3fc310b96a2fc1b54ee7c85ce5375

This message does not exist in this form in the release-2.4 branch.

Close the portfiles after reading ​https://github.com/macports/macports-base/commit/c2df3cc958635f7ac6d0983288723c6ea097b221

Was already released with 2.4.2, [ca215c1500181ce7942476d439780a9a155499e4/macports-base].

Note sure about this one:

Ignore case in livecheck regexps ​https://github.com/macports/macports-base/commit/0310feb5f4c3858e067e3500936f6fa099c78803

Should we really introduce such a change in behavior in a patch release?

Last edited 2 years ago by raimue (Rainer Müller) (previous) (diff)

comment:3 Changed 2 years ago by raimue (Rainer Müller)

In 6782b97dbb9fadf399c52d11dd455a94642aa5f4/macports-base:

ChangeLog: Update for backports to release-2.4

See: #56018

comment:4 Changed 2 years ago by raimue (Rainer Müller)

In 6a3a0ed11e55f8d5c1b2f7d349a77230e6f74293/macports-base:

ChangeLog: Update for backports to release-2.4

See: #56018
(cherry picked from commit 6782b97dbb9fadf399c52d11dd455a94642aa5f4)

comment:5 in reply to:  2 Changed 2 years ago by neverpanic (Clemens Lang)

Replying to raimue:

Not sure about this one:

Ignore case in livecheck regexps ​https://github.com/macports/macports-base/commit/0310feb5f4c3858e067e3500936f6fa099c78803

Should we really introduce such a change in behavior in a patch release?

It's not a big change, and most people probably didn't expect the regexes to be case-sensitive anyway, but I agree it's a change of behavior. We could leave it out, but it's probably not harmful to cherry-pick it either.

comment:6 Changed 2 years ago by mojca (Mojca Miklavec)

I would backport support for cargo from d1271bcdd3 as well.

comment:7 in reply to:  6 Changed 2 years ago by raimue (Rainer Müller)

Replying to mojca:

I would backport support for cargo from d1271bcdd3 as well.

This has been reverted on master as it did not work as intended.

comment:8 Changed 2 years ago by raimue (Rainer Müller)

In b3fdb86dfc5cecf87933718e96f8792290e2f0ed/macports-base:

ChangeLog: Update for backport to 2.4

See: #56018
(cherry picked from commit 6a2c538e124314826bbbb6bdb301639e4657bcfb)

comment:9 Changed 2 years ago by raimue (Rainer Müller)

In 6a2c538e124314826bbbb6bdb301639e4657bcfb/macports-base:

ChangeLog: Update for backport to 2.4

See: #56018

comment:10 Changed 2 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Everything has been merged for 2.4.3.

Note: See TracTickets for help on using tickets.