Opened 3 years ago

Closed 3 years ago

#56069 closed defect (duplicate)

gtk3 @3.22.28+quartz: Package 'gl', required by 'epoxy', not found

Reported by: Anderson-Council Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: gtk3

Description

Trying to install kde4-kile I get a fatal error while configuring gtk3 on macOs 10.13.3

Attachments (2)

main.log (110.6 KB) - added by Anderson-Council 3 years ago.
main.log
config.log (116.0 KB) - added by Anderson-Council 3 years ago.
config.log

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by Anderson-Council

Attachment: main.log added

main.log

Changed 3 years ago by Anderson-Council

Attachment: config.log added

config.log

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Cc: devans@… removed
Owner: set to dbevans
Status: newassigned

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

Summary: kde4-kile @2.1.3: configuration problem for gtk3 on high sierragtk3 @3.22.28+quartz: Package 'gl', required by 'epoxy', not found

The relevant error message is:

Package 'gl', required by 'epoxy', not found

A comment in the libepoxy portfile says:

# Yes, mesa and xorg-libX11 are *build* dependencies.  The library will function correctly
# if they are not present because it loads mesa dynamically only when GLX is used.  When
# OpenGL.framework is used, there is no need to have mesa at runtime.
#
# Clients of this library must link mesa directly and have it listed as their dependency
# in order to use mesa with libepoxy.

gtk3 always declares a dependency on libepoxy, but only declares a dependency on mesa when using the x11 variant, hence the problem, since you're using the quartz variant.

comment:3 in reply to:  2 Changed 3 years ago by Anderson-Council

Thank you for your reply. Since I'm not an expert, could you please tell me which is a possible solution of this issue? Do I have to eliminate the quartz variant?

Replying to ryandesign:

The relevant error message is:

Package 'gl', required by 'epoxy', not found

A comment in the libepoxy portfile says:

# Yes, mesa and xorg-libX11 are *build* dependencies.  The library will function correctly
# if they are not present because it loads mesa dynamically only when GLX is used.  When
# OpenGL.framework is used, there is no need to have mesa at runtime.
#
# Clients of this library must link mesa directly and have it listed as their dependency
# in order to use mesa with libepoxy.

gtk3 always declares a dependency on libepoxy, but only declares a dependency on mesa when using the x11 variant, hence the problem, since you're using the quartz variant.

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #55967, which has been fixed.

Note: See TracTickets for help on using tickets.