Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#56125 closed defect (invalid)

py27-goocanvas: destroot failure on mac OS 10.11.6

Reported by: mohibi Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: py-goocanvas

Description (last modified by mf2k (Frank Schima))

166:~ mohibihussain$ sudo port install  py27-pygraphviz py27-goocanvas py27-kiwi
Password:
Warning: xcodebuild exists but failed to execute
Warning: Xcode does not appear to be installed; most ports will likely fail to build.
--->  Computing dependencies for py27-pygraphviz
--->  Cleaning py27-pygraphviz
Warning: Xcode does not appear to be installed; most ports will likely fail to build.
Warning: All compilers are either blacklisted or unavailable; defaulting to first fallback option
Warning: All compilers are either blacklisted or unavailable; defaulting to first fallback option
--->  Computing dependencies for py27-goocanvas
--->  Staging py27-goocanvas into destroot
Error: Failed to destroot py27-goocanvas: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-goocanvas/py27-goocanvas/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
 
Error: Processing of port py27-goocanvas failed

Change History (2)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Keywords: py27-pygraphviz py27-goocanvas py27-kiwi removed
Port: py-goocanvas added
Resolution: invalid
Status: newclosed
Summary: py27-pygraphviz py27-goocanvas py27-kiwi for Macports with mac OS 10.11.6py27-goocanvas: destroot failure on mac OS 10.11.6

In the future, please use WikiFormatting, fill in the Port field and Cc the port maintainer(s) (port info --maintainers py27-goocanvas), if any.

You have provided no useful information to debug your problem. Please attach the main.log file after cleaning the port (sudo port clean py27-goocanvas) and re-open the ticket.

However, I'm guessing the problem is the one listed in the output you provided. Namely:

Warning: xcodebuild exists but failed to execute
Warning: Xcode does not appear to be installed; most ports will likely fail to build.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)
Note: See TracTickets for help on using tickets.