Opened 3 years ago

Closed 3 years ago

#56144 closed defect (fixed)

ghostscript @9.23: error: expected ')'

Reported by: iefdev (Eric F) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: haspatch Cc: Schamschula (Marius Schamschula), tehcog (tehcog), ci42
Port: ghostscript

Description

:info:build 18 errors generated.

There are too many errors to list here. They're all in the log.

 

There's another ticket with ghostscript: #56137

I have no idea if it could be related, more than I'm also upgrading my ImageMagick, where it fails.

Attachments (1)

ghostscript_main.log (136.1 KB) - added by iEFdev 3 years ago.

Download all attachments as: .zip

Change History (13)

Changed 3 years ago by iEFdev

Attachment: ghostscript_main.log added

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: Schamschula added
Summary: Ghostscript fail to build/upgrade.ghostscript @9.23: error: expected ')'

comment:2 Changed 3 years ago by tehcog (tehcog)

Cc: tehcog added

comment:3 Changed 3 years ago by tehcog (tehcog)

Mavericks

comment:4 Changed 3 years ago by dyne2meter

Still fails with same paren errors as above. Except this time, it asked me to (force) deactivate my current ghostscript version, which I then couldn't re-activate. Brilliant!

Last edited 3 years ago by dyne2meter (previous) (diff)

comment:5 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added

Why couldn't you reactivate it?

The requirement to deactivate the old version has been removed; we found a better way to fix the problem that had caused us to require that.

I can confirm this error on our 10.9 buildbot worker too.

comment:6 in reply to:  5 Changed 3 years ago by iEFdev

Replying to ryandesign:

I can confirm this error on our 10.9 buildbot worker too.

Perhaps I should add that to kwords?

(ie Lion, Mavericks)

comment:7 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ci42 added

Duplicate #56179 was filed against Yosemite. It built successfully on our Yosemite buildbot worker, though. Christoph, what version of Xcode and clang do you have?

comment:8 Changed 3 years ago by ryandesign (Ryan Schmidt)

Our 10.9 buildbot worker, where it fails, has:

$ xcodebuild -version
Xcode 6.2
Build version 6C131e
$ clang -v
Apple LLVM version 6.0 (clang-600.0.57) (based on LLVM 3.5svn)
Target: x86_64-apple-darwin13.4.0
Thread model: posix

Our 10.10 buildbot worker, where it succeeds, has:

$ xcodebuild -version
Xcode 7.2.1
Build version 7C1002
$ clang -v
Apple LLVM version 7.0.2 (clang-700.1.81)
Target: x86_64-apple-darwin14.5.0
Thread model: posix

comment:9 in reply to:  7 Changed 3 years ago by ci42

Replying to ryandesign:

Duplicate #56179 was filed against Yosemite. It built successfully on our Yosemite buildbot worker, though. Christoph, what version of Xcode and clang do you have?

$ xcodebuild -version
Xcode 6.4
Build version 6E35b
$ clang -v
Apple LLVM version 6.1.0 (clang-602.0.53) (based on LLVM 3.6.0svn)
Target: x86_64-apple-darwin14.5.0
Thread model: posix

I'll upgrade Xcode/clang and try again.

comment:10 Changed 3 years ago by ryandesign (Ryan Schmidt)

I think this was caused by this commit, which added gs_restrict to these functions:

http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=3b24fd02b2bbeaef3d2e0374023fa330a9cddeac

I think is was fixed by this commit, which added a definition for gs_restrict for C99-mode compilers.

http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=b24a4bd9bab156443c4667d4266e3deb43f933f7

clang used C99 by default in 3.5 and earlier but C11 in 3.6 and later.

comment:11 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign removed
Keywords: haspatch added
Owner: set to ryandesign
Status: newaccepted

I can reproduce the problem on newer versions of clang by adding configure.cflags-append -std=c99 to the Portfile, and I can confirm that the patch fixes the problem.

comment:12 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: acceptedclosed

In 5ee5a8600f735eb04f07d894088367ba1f506e84/macports-ports:

ghostscript: Fix build failure on C99-mode compilers

This affected clang from Xcode 6 and earlier.

Closes: #56144

Note: See TracTickets for help on using tickets.