Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#56151 closed defect (worksforme)

valgrind-devel @3.14.0-r2017-11-21: error: Failed to connect to sourceware.org port 80: Operation timed out

Reported by: jpwhiting (Jeremy Whiting) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc:
Port: valgrind-devel

Description (last modified by ryandesign (Ryan Schmidt))

When trying to install valgrind-devel here on macos 10.13.3 I get the following failure in the valgrind-devel.log file:

:debug:fetch Executing: /usr/bin/git clone --progress http://sourceware.org/git/valgrind.git /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_valgrind/valgrind-devel/work/valgrind-3.14.0-r2017-11-21 2>&1
:debug:fetch system: /usr/bin/git clone --progress http://sourceware.org/git/valgrind.git /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_valgrind/valgrind-devel/work/valgrind-3.14.0-r2017-11-21 2>&1
:info:fetch Cloning into '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_valgrind/valgrind-devel/work/valgrind-3.14.0-r2017-11-21'...
:info:fetch error: Failed to connect to sourceware.org port 80: Operation timed out (curl_result = 7, http_code = 0, sha1 = 5cc37e7df89765908efbd1edca9753c3ba97c647)
:info:fetch error: Unable to find e9fefacc2cd8458d3c2afa4364e9fdde2cfa9589 under http://sourceware.org/git/valgrind.git
:info:fetch Cannot obtain needed blob e9fefacc2cd8458d3c2afa4364e9fdde2cfa9589
:info:fetch while processing commit dc0ca811ecc91d6180656438753d86c9b4a6d2f7.
:info:fetch error: fetch failed.
:info:fetch Command failed: /usr/bin/git clone --progress http://sourceware.org/git/valgrind.git /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_valgrind/valgrind-devel/work/valgrind-3.14.0-r2017-11-21 2>&1
:info:fetch Exit code: 128
:error:fetch Failed to fetch valgrind-devel: Git clone failed
:debug:fetch Error code: NONE
:debug:fetch Backtrace: Git clone failed
:debug:fetch     while executing
:debug:fetch "gitfetch"
:debug:fetch     (procedure "portfetch::fetch_main" line 14)
:debug:fetch     invoked from within
:debug:fetch "$procedure $targetname"
:error:fetch See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_valgrind/valgrind-devel/main.log for details.

Change History (7)

comment:1 Changed 2 years ago by kencu (Ken)

Description: modified (diff)
Owner: set to raimue
Port: valgrind-devel added
Status: newassigned
Summary: valgrind-devel port fails to install because git repository no longer has commitvalgrind-devel @3.14.0-r2017-11-21: fails to install because git repository no longer has commit

comment:2 Changed 2 years ago by kencu (Ken)

I noticed a similar error last night when trying to update valgrind-devel to the latest commit. I didn't try the existing version (which I already had installed).

comment:3 Changed 2 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Summary: valgrind-devel @3.14.0-r2017-11-21: fails to install because git repository no longer has commitvalgrind-devel @3.14.0-r2017-11-21: error: Failed to connect to sourceware.org port 80: Operation timed out

I get the same error. It fetches for a few minutes, then times out.

comment:4 Changed 2 years ago by kencu (Ken)

I betcha https might work...

comment:5 Changed 2 years ago by kencu (Ken)

https didn't work, but using macports newer git version did

    fetch.type      git
+    git.cmd         ${prefix}/bin/git
    git.url         http://sourceware.org/git/valgrind.git
    git.branch      0a5ff8c309d18778bb919a1a661a1976b04a6483

comment:6 Changed 2 years ago by raimue (Rainer Müller)

Resolution: worksforme
Status: assignedclosed

I cannot reproduce the problem. I assume this was a temporary problem on the server-side.

@Ken: Feel free to push updates to the valgrind-devel port whenever you want. I am not using it much anymore, so I often forget updating it.

comment:7 Changed 2 years ago by raimue (Rainer Müller)

In 500e02af16a49d4830dc0560eb289d0d2702debc/macports-ports (master):

valgrind-devel: Switch to recommended Git mirror

There have been some reports that the sourceware.org Git repository does
not work reliable over HTTP. Use the Git mirror recommended by the
valgrind website at http://www.valgrind.org/downloads/repository.html

See: #56151
Closes: #56532

Note: See TracTickets for help on using tickets.