Opened 3 years ago

Closed 2 years ago

#56209 closed defect (worksforme)

qt5: incompatible Qt library version

Reported by: mojca (Mojca Miklavec) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: michaelld (Michael Dickens), chrstphrchvz (Christopher Chavez)
Port: qt5

Description

While trying to upgrade xpdf, the port built fine, but it failed to run:

Cannot mix incompatible Qt library (version 0x50a00) with this library (version 0x50a01)
Abort trap: 6

I have no clue what this means, but I suspect that one of the libraries was not revbumped when Qt was updated.

I'm using 10.13. I'll put a slightly longer log in comment.

Change History (6)

comment:1 Changed 3 years ago by mojca (Mojca Miklavec)

> export QT_DEBUG_PLUGINS=1
> xpdf
QFactoryLoader::QFactoryLoader() checking directory path "/opt/local/libexec/qt5/plugins/platforms" ...
QFactoryLoader::QFactoryLoader() looking at "/opt/local/libexec/qt5/plugins/platforms/libqcocoa.dylib"
Found metadata in lib /opt/local/libexec/qt5/plugins/platforms/libqcocoa.dylib, metadata=
{
    "IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
    "MetaData": {
        "Keys": [
            "cocoa"
        ]
    },
    "className": "QCocoaIntegrationPlugin",
    "debug": false,
    "version": 330241
}


Got keys from plugin meta data ("cocoa")
QFactoryLoader::QFactoryLoader() looking at "/opt/local/libexec/qt5/plugins/platforms/libqminimal.dylib"
Found metadata in lib /opt/local/libexec/qt5/plugins/platforms/libqminimal.dylib, metadata=
{
    "IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
    "MetaData": {
        "Keys": [
            "minimal"
        ]
    },
    "className": "QMinimalIntegrationPlugin",
    "debug": false,
    "version": 330241
}


Got keys from plugin meta data ("minimal")
QFactoryLoader::QFactoryLoader() looking at "/opt/local/libexec/qt5/plugins/platforms/libqoffscreen.dylib"
Found metadata in lib /opt/local/libexec/qt5/plugins/platforms/libqoffscreen.dylib, metadata=
{
    "IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3",
    "MetaData": {
        "Keys": [
            "offscreen"
        ]
    },
    "className": "QOffscreenIntegrationPlugin",
    "debug": false,
    "version": 330241
}


Got keys from plugin meta data ("offscreen")
QFactoryLoader::QFactoryLoader() checking directory path "/opt/local/bin/platforms" ...
loaded library "/opt/local/libexec/qt5/plugins/platforms/libqcocoa.dylib"
QFactoryLoader::QFactoryLoader() checking directory path "/opt/local/libexec/qt5/plugins/platformthemes" ...
QFactoryLoader::QFactoryLoader() checking directory path "/opt/local/bin/platformthemes" ...
QFactoryLoader::QFactoryLoader() checking directory path "/opt/local/libexec/qt5/plugins/styles" ...
QFactoryLoader::QFactoryLoader() looking at "/opt/local/libexec/qt5/plugins/styles/libqmacstyle.dylib"
Found metadata in lib /opt/local/libexec/qt5/plugins/styles/libqmacstyle.dylib, metadata=
{
    "IID": "org.qt-project.Qt.QStyleFactoryInterface",
    "MetaData": {
        "Keys": [
            "macintosh"
        ]
    },
    "className": "QMacStylePlugin",
    "debug": false,
    "version": 330241
}


Got keys from plugin meta data ("macintosh")
QFactoryLoader::QFactoryLoader() checking directory path "/opt/local/bin/styles" ...
loaded library "/opt/local/libexec/qt5/plugins/styles/libqmacstyle.dylib"
Config Error: No display font for 'Helvetica-Bold'
Config Error: No display font for 'Times-Bold'
Config Error: No display font for 'Times-BoldItalic'
Config Error: No display font for 'Times-Italic'
Config Error: No display font for 'Times-Roman'
QFactoryLoader::QFactoryLoader() checking directory path "/opt/local/libexec/qt5/plugins/iconengines" ...
QFactoryLoader::QFactoryLoader() looking at "/opt/local/libexec/qt5/plugins/iconengines/libqsvgicon.dylib"
Found metadata in lib /opt/local/libexec/qt5/plugins/iconengines/libqsvgicon.dylib, metadata=
{
    "IID": "org.qt-project.Qt.QIconEngineFactoryInterface",
    "MetaData": {
        "Keys": [
            "svg",
            "svgz",
            "svg.gz"
        ]
    },
    "className": "QSvgIconPlugin",
    "debug": false,
    "version": 330240
}


Got keys from plugin meta data ("svg", "svgz", "svg.gz")
QFactoryLoader::QFactoryLoader() checking directory path "/opt/local/bin/iconengines" ...
loaded library "/opt/local/libexec/qt5/plugins/iconengines/libqsvgicon.dylib"
Cannot mix incompatible Qt library (version 0x50a00) with this library (version 0x50a01)
Abort trap: 6

comment:2 Changed 3 years ago by mojca (Mojca Miklavec)

Cc: MarcusCalhoun-Lopez removed
Owner: set to MarcusCalhoun-Lopez
Status: newassigned

comment:3 Changed 3 years ago by chrstphrchvz (Christopher Chavez)

This looks similar to the issue in #55566--are there multiple versions of qt5 libraries active? That is, is there output from both port echo active | grep 'qt5.* @5.10.1' and port echo active | grep 'qt5.* @5.10.0', or does only one of them output anything? Should qt5 ports be enforcing that only one particular version be active at a time?

comment:4 Changed 3 years ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:5 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Sadly, I am unable to reproduce this error.
Is there still an issue?

comment:6 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: worksforme
Status: assignedclosed

Closing since there was no response to queries.
Please fee free to reopen if the problem persists.

Note: See TracTickets for help on using tickets.