Opened 2 years ago

Closed 2 years ago

#56253 closed defect (invalid)

jack @1.9.12 (audio) Install failed

Reported by: fusionx (Prashant Chaudhary) Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc: carlesfernandez (Carles Fernandez)
Port: jack

Description (last modified by neverpanic (Clemens Lang))

As part of GQRX installation, jack keeps failing even after cleaning a few times.

--->  Fetching archive for jack
--->  Attempting to fetch jack-1.9.12_0.darwin_17.x86_64.tbz2 from https://packages.macports.org/jack
--->  Attempting to fetch jack-1.9.12_0.darwin_17.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/jack
--->  Attempting to fetch jack-1.9.12_0.darwin_17.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/jack
--->  Fetching distfiles for jack
--->  Attempting to fetch jack2-1.9.12.tar.gz from https://distfiles.macports.org/jack
--->  Verifying checksums for jack
--->  Extracting jack
--->  Configuring jack
--->  Building jack
Error: Failed to build jack: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_audio_jack/jack/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port gqrx failed

Attachments (4)

main.log (235.0 KB) - added by neverpanic (Clemens Lang) 2 years ago.
main.2.log (41.5 KB) - added by fusionx (Prashant Chaudhary) 2 years ago.
results of "sudo port -t install --unrequested jack"
main.3.log (16.0 KB) - added by fusionx (Prashant Chaudhary) 2 years ago.
Results of the install with trace mode
main.4.log (308.4 KB) - added by fusionx (Prashant Chaudhary) 2 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 2 years ago by neverpanic (Clemens Lang)

Description: modified (diff)

Please attach large amounts of output rather than pasting them.

Does this also happen if you build with port -t, e.g. port -t upgrade jack?

Changed 2 years ago by neverpanic (Clemens Lang)

Attachment: main.log added

comment:2 Changed 2 years ago by neverpanic (Clemens Lang)

Owner: set to neverpanic
Status: newassigned

comment:3 Changed 2 years ago by fusionx (Prashant Chaudhary)

I will make sure to post large chunks as attachments.

This happens at the initial install time with gqrx. Then I tried to build jack using sudo port install jack, but it kept failing. I just tried the -t option sudo port -t install jack, but here is the error that I get:

sudo port -t install jack
--->  Computing dependencies for jack
--->  Building jack
Warning: The following existing file was hidden from the build system by trace mode:
  /var/db/timezone/zoneinfo/America/Los_Angeles
Error: Failed to build jack: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_audio_jack/jack/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port jack failed

The file /var/db/timezone/zoneinfo/America/Los_Angeles is visible and read-only for everyone, so I am not sure why that would cause problems.

comment:4 Changed 2 years ago by neverpanic (Clemens Lang)

Oh, I should have been more detailed with the instructions, sorry. Please do the following:

sudo port clean jack
sudo port -t install --unrequested jack

If it fails again, please attach the main.log.

The reason why I'm asking is that the function used in the jack codebase, regcomp is in fact provided by libSystem.dylib, but for some reason your build is looking for regcompA instead. The only way I could explain that is that for some reason, your build of jack does not include regex.h like it should, but boost/regex.h, a header installed by boost, which includes a #define regcomp regcompA – however, the boost headers should never be used without the boost/ prefix; this means that either your build of jack is compiling with -I/opt/local/include/boost (that doesn't seem to be the case), or you have a copy of boost in a place where it shouldn't be, e.g. directly in /usr/local/include. Building with trace mode -t should hide files that shouldn't be there from jack's build system, which may fix this issue.

Changed 2 years ago by fusionx (Prashant Chaudhary)

Attachment: main.2.log added

results of "sudo port -t install --unrequested jack"

comment:5 Changed 2 years ago by fusionx (Prashant Chaudhary)

After running the command, it seems the failure is at the end of the file when it tries to uncompress jack.

:info:extract Executing:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_audio_jack/jack/work" && /usr/bin/gzip -dc '/opt/local/var/macports/distfiles/jack/jack2-1.9.12.tar.gz' | /usr/bin/tar -xf -
:debug:extract system:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_audio_jack/jack/work" && /usr/bin/gzip -dc '/opt/local/var/macports/distfiles/jack/jack2-1.9.12.tar.gz' | /usr/bin/tar -xf -
:info:extract sh: /usr/bin/tar: No such file or directory
:info:extract gzip: error writing to output: Broken pipe
:info:extract gzip: /opt/local/var/macports/distfiles/jack/jack2-1.9.12.tar.gz: uncompress failed
:info:extract Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_audio_jack/jack/work" && /usr/bin/gzip -dc '/opt/local/var/macports/distfiles/jack/jack2-1.9.12.tar.gz' | /usr/bin/tar -xf -
:info:extract Exit code: 127
:error:extract Failed to extract jack: command execution failed
:debug:extract Error code: NONE
:debug:extract Backtrace: command execution failed
:debug:extract     while executing
:debug:extract "$procedure $targetname"
:error:extract See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_audio_jack/jack/main.log for details.

I checked that the tar executable is there at /usr/bin/tar It may be a permissions issue in the directory where it is trying to extract.

comment:6 Changed 2 years ago by neverpanic (Clemens Lang)

Oh, you're currently hitting #55575, which will be fixed in MacPorts 2.4.3. Try

sudo port extract jack
sudo port -t install --unrequested jack

instead; that should allow the build to continue.

comment:7 Changed 2 years ago by fusionx (Prashant Chaudhary)

Thanks for your patience with this. I still encountered a failure when running it with trace mode set on.

sudo port -t install --unrequested jack
--->  Computing dependencies for jack
--->  Activating jack @1.9.12_0
Error: Failed to activate jack: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_audio_jack/jack/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port jack failed

The relevant lines from the main.log are below:

:msg:activate --->  Activating jack @1.9.12_0
:debug:activate Using /usr/bin/tar
:debug:activate Using /usr/bin/bzip2
:debug:activate system: /usr/bin/bzip2 -d -c /opt/local/var/macports/software/jack/jack-1.9.12_0.darwin_17.x86_64.tbz2 | ( /usr/bin/tar -xvpf - )
:info:activate sh: /usr/bin/tar: No such file or directory
:info:activate Command failed: /usr/bin/bzip2 -d -c /opt/local/var/macports/software/jack/jack-1.9.12_0.darwin_17.x86_64.tbz2 | ( /usr/bin/tar -xvpf - )
:info:activate Exit code: 127
:error:activate Failed to activate jack: command execution failed
:debug:activate Error code: CHILDSTATUS 16242 127
:debug:activate Backtrace: command execution failed

comment:8 Changed 2 years ago by neverpanic (Clemens Lang)

OK, but your build continued to activation phase, which means that the build successfully finished. This also means that your problem was caused by a file that was hidden by trace mode.

Please attach the main.log for this attempt, since its trace mode warnings will probably explain why the build fails.

Changed 2 years ago by fusionx (Prashant Chaudhary)

Attachment: main.3.log added

Results of the install with trace mode

comment:9 Changed 2 years ago by neverpanic (Clemens Lang)

For some reason your log jupms from computing dependencies directly to activating, so the actual build phase is not being run, which also suggests that you already have a built copy of jack 1.9.12.

Can you try running sudo port activate jack @1.9.12_0?

comment:10 Changed 2 years ago by carlesfernandez (Carles Fernandez)

Cc: carlesfernandez added

comment:11 Changed 2 years ago by fusionx (Prashant Chaudhary)

Yes, the commands that I have run in the past are

sudo port extract jack
sudo port -t install --unrequested jack

After running activation command of sudo port activate jack @1.9.12_0, I get the following error:

--->  Computing dependencies for jack
--->  Activating jack @1.9.12_0
Error: Failed to activate jack: Image error: Source file /opt/local/var/macports/software/jack/mpextractyndOzhsw/opt/local/bin/jack_alias does not appear to exist (cannot lstat it).  Unable to activate port jack.
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_registry_portfiles_jack-1.9.12_0_39f80d202647417b19b7a43ede8d3739914b590245f053301b19f85117dd0e87-2499/jack/main.log for details.
Warning: Failed to execute portfile from registry for jack @1.9.12_0
--->  Activating jack @1.9.12_0
Error: port activate failed: Image error: Source file /opt/local/var/macports/software/jack/mpextractTuVNtkM6/opt/local/bin/jack_alias does not appear to exist (cannot lstat it).  Unable to activate port jack.

Main.log also has the same error in there. Here are the relevant lines:

:msg:activate --->  Activating jack @1.9.12_0
:debug:activate Using /usr/bin/tar
:debug:activate Using /usr/bin/bzip2
:debug:activate system: /usr/bin/bzip2 -d -c /opt/local/var/macports/software/jack/jack-1.9.12_0.darwin_17.x86_64.tbz2 | ( /usr/bin/tar -xvpf - )
:error:activate Failed to activate jack: Image error: Source file /opt/local/var/macports/software/jack/mpextractyndOzhsw/opt/local/bin/jack_alias does not appear to exist (cannot lstat it).  Unable to activate port jack.
:debug:activate Error code: registry::image-error
:debug:activate Backtrace: Image error: Source file /opt/local/var/macports/software/jack/mpextractyndOzhsw/opt/local/bin/jack_alias does not appear to exist (cannot lstat it).  Unable to activate port jack.

comment:12 Changed 2 years ago by neverpanic (Clemens Lang)

Somehow your jack port is in an inconsistent state. Please run

sudo port clean jack
sudo port extract jack
sudo port -st destroot jack

and attach the main.log. If that succeeded, you can also run

sudo port -s install --unrequested jack

to upgrade to the new jack version.

Changed 2 years ago by fusionx (Prashant Chaudhary)

Attachment: main.4.log added

comment:13 Changed 2 years ago by fusionx (Prashant Chaudhary)

sudo port clean jack

--->  Cleaning jack

sudo port extract jack

--->  Fetching distfiles for jack
--->  Verifying checksums for jack
--->  Extracting jack

sudo port -st destroot jack

--->  Computing dependencies for jack
--->  Configuring jack
Warning: The following existing file was hidden from the build system by trace mode:
  /var/db/timezone/zoneinfo/America/Los_Angeles
--->  Building jack
Warning: The following existing files were hidden from the build system by trace mode:
  /usr/local/include/regex.h
  /var/db/timezone/zoneinfo/America/Los_Angeles
--->  Staging jack into destroot
Warning: The following existing files were hidden from the build system by trace mode:
  /var/db/timezone/zoneinfo/America/Los_Angeles
  /var/root/.CFUserTextEncoding

main.4.log added to the ticket

sudo port -s install --unrequested jack

--->  Computing dependencies for jack
--->  Activating jack @1.9.12_0
Error: Failed to activate jack: Image error: Source file /opt/local/var/macports/software/jack/mpextractUJymW3aq/opt/local/bin/jack_alias does not appear to exist (cannot lstat it).  Unable to activate port jack.
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_audio_jack/jack/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port jack failed

comment:14 Changed 2 years ago by neverpanic (Clemens Lang)

Resolution: invalid
Status: assignedclosed

Thanks, there it is:

Warning: The following existing files were hidden from the build system by trace mode:
  /usr/local/include/regex.h

For some reason you have a copy of boost/regex.h in /usr/local. See wiki:FAQ#usrlocal on why this is a bad idea.

Note: See TracTickets for help on using tickets.