Opened 2 years ago

Last modified 2 years ago

#56256 new defect

subsurface: broken dependencies, outdated

Reported by: mojca (Mojca Miklavec) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: elelay (Eric Le Lay)
Port: subsurface

Description (last modified by mojca (Mojca Miklavec))

The subsurface port depends on gtk-osx-application which uses a somewhat non-standard way to declare its obsoleteness:

The gtk-osx-application port has been replaced by 'gtk-osx-application-gtk2'
and 'gtk-osx-application-gtk3'.
Please `sudo port deactivate gtk-osx-application`
followed by `sudo port upgrade -u outdated` or another command to update.
Then if all works as intended `sudo port uninstall gtk-osx-application`

The subsurface port needs to up upgraded and the dependencies need to be fixed.

If taking care of this, see also #54839.

Change History (1)

comment:1 Changed 2 years ago by mojca (Mojca Miklavec)

Description: modified (diff)
Note: See TracTickets for help on using tickets.