Opened 2 years ago

Closed 2 years ago

#56270 closed defect (duplicate)

mysql57 @5.7.17: error: no member named 'ifr_ifrn' in 'ifreq'; did you mean 'ifr_ifru'?

Reported by: KiyoshiGotow Owned by: pixilla (Bradley Giesbrecht)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: mysql57

Description (last modified by ryandesign (Ryan Schmidt))

When I tried to upgrade amavisd-new to 2.10.1_6 from 2.10.1_5, I got an error message regarding mysql57 installation.

I attach main.log in /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mysql57/mysql57/

The followings is the output from the console.

$ sudo port upgrade amavisd-new
Password:
--->  Computing dependencies for mysql57
--->  Fetching archive for mysql57
...
...
--->  Verifying checksums for mysql57                                                
--->  Extracting mysql57
--->  Applying patches to mysql57
--->  Configuring mysql57
--->  Building mysql57
Error: Failed to build mysql57: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mysql57/mysql57/main.log for details.
Error: Problem while installing mysql57
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Attachments (1)

main.log (6.1 MB) - added by KiyoshiGotow 2 years ago.

Change History (3)

Changed 2 years ago by KiyoshiGotow

Attachment: main.log added

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: set to pixilla
Port: mysql57 added
Status: newassigned
Summary: Failed to build mysql57 while upgrading amavisd-new 2.10.1_6mysql57 @5.7.17: error: no member named 'ifr_ifrn' in 'ifreq'; did you mean 'ifr_ifru'?

Duplicate of #55238.

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.