Opened 2 years ago

Closed 2 years ago

#56316 closed defect (duplicate)

osxfuse-3.7.1_0.darwin_17.x86_64: Fails to build

Reported by: willbprog127 (Will Brokenbourgh) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.4.3
Keywords: highsierra Cc:
Port: osxfuse

Description

When attempting to install osxfuse 3.7.1_0 the install process fails:

$ sudo port install osxfuse
Password:
--->  Computing dependencies for osxfuse
--->  Fetching archive for osxfuse
--->  Attempting to fetch osxfuse-3.7.1_0.darwin_17.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/osxfuse
--->  Attempting to fetch osxfuse-3.7.1_0.darwin_17.x86_64.tbz2 from https://packages.macports.org/osxfuse
--->  Attempting to fetch osxfuse-3.7.1_0.darwin_17.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/osxfuse
--->  Fetching distfiles for osxfuse
--->  Attempting to fetch osxfuse-431bdc5.tar.gz from https://github.com/osxfuse/osxfuse/tarball/431bdc5/
--->  Attempting to fetch kext-0a73539.tar.gz from https://github.com/osxfuse/kext/tarball/0a73539/
--->  Attempting to fetch framework-e1df643.tar.gz from https://github.com/osxfuse/framework/tarball/e1df643/
--->  Attempting to fetch prefpane-8a65eb2.tar.gz from https://github.com/osxfuse/prefpane/tarball/8a65eb2/
--->  Attempting to fetch fuse-559738e.tar.gz from https://github.com/osxfuse/fuse/tarball/559738e/
--->  Attempting to fetch support-19b4e8b.tar.gz from https://github.com/osxfuse/support/tarball/19b4e8b/
--->  Attempting to fetch osxfuse-3.7.1.dmg from https://github.com/osxfuse/osxfuse/releases/download/osxfuse-3.7.1
--->  Verifying checksums for osxfuse                                                
--->  Extracting osxfuse
--->  Configuring osxfuse
--->  Building osxfuse
Error: Failed to build osxfuse: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port osxfuse failed

My configuration:

  • macOS 10.13.4 (High Sierra)
  • Mac Mini (late 2012) 2.5 GHz 2 cores
  • 16 GB RAM
  • 500 GB hdd
  • Xcode Version 9.3 (9E145) + command-line utilities

Attachments (1)

main.log (711.8 KB) - added by willbprog127 (Will Brokenbourgh) 2 years ago.

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by willbprog127 (Will Brokenbourgh)

Attachment: main.log added

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Owner: set to drkp
Port: osxfuse added; osxfuse-3.7.1_0.darwin_17.x86_64 removed
Status: newassigned

In the future, please Cc the port maintainer(s) (port info --maintainers osxfuse), if any.

comment:2 Changed 2 years ago by ryandesign (Ryan Schmidt)

Keywords: highsierra added
Resolution: duplicate
Status: assignedclosed

The error shown in the main.log is:

:info:build /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': dlopen(/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle, 0x0009): required dylib '@rpath/libclang.dylib' not found, needed by '/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle'.  Did try: file not found '/Applications/Xcode.app/Contents/Developer/Toolchains/OSX10.13.xctoolchain/usr/lib/libclang.dylib', file not found '/usr/lib/libclang.dylib', file not found '/usr/local/lib/libclang.dylib' - /System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle (LoadError)

So this is a duplicate of #54939.

Note: See TracTickets for help on using tickets.