Opened 3 years ago

Closed 3 years ago

#56445 closed defect (duplicate)

hdf5 - Headers are 1.10.1, library is 1.10.2

Reported by: smalleyr Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.4.4
Keywords: Cc:
Port: gmt4 gmt5

Description (last modified by mf2k (Frank Schima))

Warning! ***HDF5 library version mismatched error***
The HDF5 header files used to compile this application do not match
the version used by the HDF5 library to which this application is linked.

Attachments (1)

main.log (99.0 KB) - added by smalleyr 3 years ago.
log file for gmt5 - which is failing install - showing Warning! *HDF5 library version mismatched error*

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 years ago by smalleyr

The problem started with a routine ports upgrade about a week ago.

I deleted all macports, home-brew, and conda installs, then upgraded from El Capitan to Sierra before using macports to attempt to reinstall GMT4 and GMT5 (actually the gmt5 install fails and I'll be submitting another ticket for this, but both gmt4 and gmt5 depend on the same hdf5 install).

There is a short, ~6 item long, GMT Forum discussion on the same problem with GMT5, that the submitter was able to fix, but it did not work for me.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Cc: takeshi@… removed
Description: modified (diff)
Owner: set to tenomoto
Status: newassigned

comment:3 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

If you're encountering a build failure, please attach the main.log so we can see what happened.

comment:5 in reply to:  1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Replying to smalleyr:

There is a short, ~6 item long, GMT Forum discussion on the same problem with GMT5, that the submitter was able to fix, but it did not work for me.

Could you give us a link to that thread?

comment:6 Changed 3 years ago by jmroot (Joshua Root)

Component: baseports

comment:7 Changed 3 years ago by smalleyr

http://gmt.soest.hawaii.edu/boards/1/topics/6903

The problem started a few weeks ago. There is another ticket - referred to in the thread - about the hdf5 problem. There are thousands of hits looking for "Warning! *HDF5 library version mismatched error*" on the web.

Both gmt4 and gmt5 suffer from this problem, although gmt4 seems to install. gmt4 runs are unstable (I have one program that runs every other call).

Changed 3 years ago by smalleyr

Attachment: main.log added

log file for gmt5 - which is failing install - showing Warning! *HDF5 library version mismatched error*

comment:8 Changed 3 years ago by tenomoto (Takeshi Enomoto)

Resolution: duplicate
Status: assignedclosed

Duplicate of #56312.

Note: See TracTickets for help on using tickets.