Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#56448 closed defect (worksforme)

wget update fails

Reported by: mouse07410 (Mouse) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: wget

Description

$ port installed wget
The following ports are currently installed:
  wget @1.19.4_3+ssl (active)
$ sudo port upgrade wget
Password:
--->  Computing dependencies for wget
--->  Configuring wget
Error: Failed to configure wget, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wget/wget/work/wget-1.19.5/config.log
Error: Failed to configure wget: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wget/wget/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
$ 

Here's what is probably the relevant part of the log (complete log attached):

. . . . .
configure:5816: /usr/bin/clang -E -I/opt/local/include conftest.c
conftest.c:15:10: fatal error: 'ac_nonexistent.h' file not found
#include <ac_nonexistent.h>
         ^~~~~~~~~~~~~~~~~~
1 error generated.
configure:5816: $? = 1
configure: failed program was:
. . . . .

Attachments (1)

wget-config.log.txt (1.6 MB) - added by mouse07410 (Mouse) 3 years ago.

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by mouse07410 (Mouse)

Attachment: wget-config.log.txt added

comment:1 Changed 3 years ago by kencu (Ken)

Might be this:

configure:45282: error: Libiconv is required for IRIs support

comment:2 Changed 3 years ago by mouse07410 (Mouse)

Might be this...

I rather doubt it, because

$ port installed libiconv
The following ports are currently installed:
  libiconv @1.15_0 (active)
$ 

comment:3 Changed 3 years ago by kencu (Ken)

this installed directly without error, at least on this system:

$ port -v installed wget
The following ports are currently installed:
  wget @1.19.5_0+gnutls (active) platform='darwin 17' archs='x86_64' date='2018-05-07T20:10:48-0700'
Last edited 3 years ago by kencu (Ken) (previous) (diff)

comment:4 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Owner: set to ryandesign
Status: newassigned

Could you attach the main.log too, please?

comment:5 Changed 3 years ago by mouse07410 (Mouse)

That was the only log produced, I think. Let me check further.

comment:6 in reply to:  description Changed 3 years ago by ryandesign (Ryan Schmidt)

This file:

Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wget/wget/main.log for details.

comment:7 Changed 3 years ago by mouse07410 (Mouse)

I'm pretty sure that's what I attached.

comment:8 Changed 3 years ago by mouse07410 (Mouse)

I've reinstalled libiconv and the problem stopped manifesting itself.

comment:9 Changed 3 years ago by kencu (Ken)

Resolution: worksforme
Status: assignedclosed

comment:10 in reply to:  7 Changed 3 years ago by ryandesign (Ryan Schmidt)

Replying to mouse07410:

I'm pretty sure that's what I attached.

No, you attached this file:

Error: Failed to configure wget, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wget/wget/work/wget-1.19.5/config.log
Note: See TracTickets for help on using tickets.