Opened 11 months ago

Closed 3 months ago

#56468 closed defect (worksforme)

inkscape: Nothing to do!

Reported by: joubfran Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.4.4
Keywords: Cc:
Port: inkscape

Description (last modified by ryandesign (Ryan Schmidt))

inkscape-app install successfully:

sudo port install inkscape-app

Also tried:

sudo port install inkscape-app +quartz

After installation, the App starts up and closes down.

Executing the app on the command line, I get the following output:

$ /Applications/MacPorts/Inkscape.app/Contents/MacOS/Inkscape 
Nothing to do!
$

Change History (7)

comment:1 Changed 11 months ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: set to dbevans
Port: inkscape added; inkscape-app removed
Status: newassigned
Summary: inkscape-app does not start up on MacOS High Sierrainkscape: Nothing to do!

There have been several other reports of the Nothing to do! error here, such as #52632, #55628, #55997. I don't know whether to close this as a duplicate of one of them, since I don't know if we found a solution to them so I don't know if your problem is the same.

What are your LANG and LC_ALL environment variables set to? Try the suggestions at comment:ticket:52632:13.

comment:2 Changed 11 months ago by joubfran

I have wasted enough time trying to get Inscape to work on Mac, I will try something else. Such a pity!

comment:3 Changed 11 months ago by ryandesign (Ryan Schmidt)

Sorry it doesn't work for you. It works for me. Without further input from those for whom it doesn't work, it's difficult for us to fix it for you...

comment:4 Changed 11 months ago by pmetzger (Perry E. Metzger)

Unless joubfran is willing to help us debug this, I think we must close this ticket. We cannot fix something without being able to reproduce the problem.

comment:5 Changed 11 months ago by joubfran

You are welcome to close this issue. I have removed Mac Ports totally from my Mac.

comment:6 Changed 3 months ago by fdesar

You get this error when quartz's not install on the system (not checked by the port) : Inkscape doesn't find any X Server so it has nothing to do!

Just download and install it from https:/www.xquartz.org

I know it is an old thread but this may help others ready it...

Last edited 3 months ago by fdesar (previous) (diff)

comment:7 Changed 3 months ago by mf2k (Frank Schima)

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.