#56473 closed defect (invalid)

nspr-4.19 does not build on a powerpc

Reported by: josephsacco Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: powerpc Cc: Schamschula (Marius Schamschula)
Port: nspr

Description

See below.

-Joseph

Undefined symbols for architecture ppc:
  "_FStar_UInt128_uint64_to_uint128", referenced from:
      _Hacl_Standalone_Poly1305_32_crypto_onetimeauth_ in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_init in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_finish in Hacl_Poly1305_32.o
  "_FStar_UInt128_shift_left", referenced from:
      _Hacl_Standalone_Poly1305_32_crypto_onetimeauth_ in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_init in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_finish in Hacl_Poly1305_32.o
  "_FStar_UInt128_logor", referenced from:
      _Hacl_Standalone_Poly1305_32_crypto_onetimeauth_ in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_init in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_finish in Hacl_Poly1305_32.o
  "_FStar_UInt128_logand", referenced from:
      _Hacl_Standalone_Poly1305_32_crypto_onetimeauth_ in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_init in Hacl_Poly1305_32.o
  "_FStar_UInt128_uint128_to_uint64", referenced from:
      _Hacl_Standalone_Poly1305_32_crypto_onetimeauth_ in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_init in Hacl_Poly1305_32.o
  "_FStar_UInt128_shift_right", referenced from:
      _Hacl_Standalone_Poly1305_32_crypto_onetimeauth_ in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_init in Hacl_Poly1305_32.o
  "_FStar_UInt128_add_mod", referenced from:
      _Hacl_Standalone_Poly1305_32_crypto_onetimeauth_ in Hacl_Poly1305_32.o
      _Hacl_Poly1305_32_finish in Hacl_Poly1305_32.o
ld: symbol(s) not found for architecture ppc

Change History (6)

comment:1 Changed 10 months ago by jmroot (Joshua Root)

Where are you getting 3.37? The only version in MacPorts appears to be 4.19.

comment:2 Changed 10 months ago by josephsacco

Mia culpa... I meant version 4.19.

I seem to have "3.37" embedded in my brain as I have been working on getting xfig and fig2dev updated from 3.37 to 3.37a.

Kindly modify the ticket title.

-Joseph

comment:3 Changed 10 months ago by Schamschula (Marius Schamschula)

Summary: nspr-3.37 does not build on a powerpcnspr-4.19 does not build on a powerpc

comment:4 Changed 10 months ago by jmroot (Joshua Root)

Well, there's an archive: http://packages.macports.org/nspr/nspr-4.19_0.darwin_9.ppc.tbz2

So it does build on at least one ppc platform. You'll need to narrow it down; a complete log would be a good start.

comment:5 Changed 10 months ago by josephsacco

Joshua,

Thank you for your patience. I think I should go do something else for a while to clear my head.

There is nothing wrong with nspr-4.19. The errant app that refuses to build on a PPC is nss-3.37.

-Joseph

comment:6 Changed 10 months ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed

OK. I'll close this ticket and you can open a new one for nss.

Note: See TracTickets for help on using tickets.