Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#56483 closed defect (duplicate)

Error updating graphene

Reported by: eolaguir (lobs) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: geoffgrimwood, dershow
Port: graphene

Description (last modified by mf2k (Frank Schima))

I get the below error when trying to update macports

--->  Staging graphene into destroot
Error: Failed to destroot graphene: error copying "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_graphene/graphene/work/destroot" to "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_graphene/graphene/work/destroot-x86_64/destroot": file already exists
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_graphene/graphene/main.log for details.
Error: rev-upgrade failed: Error rebuilding gstreamer1-gst-plugins-good

said error happened after updating macports

Attachments (2)

main.log (40.6 KB) - added by hugo-ribeiro (Hugo Ribeiro) 3 years ago.
graphene.log (169.1 KB) - added by thetrial (alabay) 3 years ago.
Graphene Log.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Keywords: graphene macports update removed
Owner: set to dbevans
Port: graphene added
Status: newassigned

In the future, please use WikiFormatting, fill in the Port field and Cc the port maintainer(s) (port info --maintainers graphene), if any.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 3 years ago by ryandesign (Ryan Schmidt)

Why does destroot already exist? I suspect an unclean build attempt. Run sudo port clean graphene, then try again.

comment:4 Changed 3 years ago by libsystem-ethan

This is caused by a bug in Meson (https://github.com/mesonbuild/meson/issues/3493). Until a new release of Meson is made, running sudo -H pip3.6 install git+git://github.com/mesonbuild/meson.git will install Meson from it's GitHub HEAD which has a fix for this issue. After running port clean graphene the build should succeed. You ought to make sure you run sudo -H "pip3.6 uninstall meson; port uninstall meson" to remove all instances of meson from your system, as installing from Pip may overwrite parts of MacPort's Meson port.

comment:5 Changed 3 years ago by ryandesign (Ryan Schmidt)

It's impossible to tell whether that's what's going on. The reporter should sudo port clean graphene and try again, and if it fails, attach the main.log file to this ticket.

Users should not attempt to overwrite files installed by MacPorts (such as meson) with other files. If there is a bug in the files installed by the meson port, we should fix the meson port.

Changed 3 years ago by hugo-ribeiro (Hugo Ribeiro)

Attachment: main.log added

comment:6 Changed 3 years ago by hugo-ribeiro (Hugo Ribeiro)

I have run into a similar problem when upgrading gstreamer1-gst-plugins-base; the newest version depends on graphene. It seems that the meson port is responsible. Here's the relevant output from port -sv upgrade outdated

Traceback (most recent call last):
  File "/opt/local/bin/meson", line 26, in <module>
    sys.exit(main())
  File "/opt/local/bin/meson", line 23, in main
    return mesonmain.run(sys.argv[1:], launcher)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/mesonbuild/mesonmain.py", line 308, in run
    sys.exit(run_script_command(args[1:]))
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/mesonbuild/mesonmain.py", line 257, in run_script_command
    return cmdfunc(cmdargs)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/mesonbuild/scripts/meson_install.py", line 390, in run
    do_install(datafilename)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/mesonbuild/scripts/meson_install.py", line 216, in do_install
    install_targets(d)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/mesonbuild/scripts/meson_install.py", line 371, in install_targets
    depfixer.fix_rpath(outname, install_rpath, False)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/mesonbuild/scripts/depfixer.py", line 391, in fix_rpath
    fix_darwin(fname, new_rpath)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/mesonbuild/scripts/depfixer.py", line 376, in fix_darwin
    subprocess.check_call(['install_name_tool', '-add_rpath', new_rpath, fname])
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/subprocess.py", line 286, in check_call
    retcode = call(*popenargs, **kwargs)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/subprocess.py", line 267, in call
    with Popen(*popenargs, **kwargs) as p:
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/subprocess.py", line 709, in __init__
    restore_signals, start_new_session)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/subprocess.py", line 1275, in _execute_child
    restore_signals, start_new_session, preexec_fn)
TypeError: expected str, bytes or os.PathLike object, not NoneType
FAILED: meson-install
/opt/local/Library/Frameworks/Python.framework/Versions/3.6/bin/python3.6 /opt/local/bin/meson --internal install /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_graphene/graphene/work/build-x86_64/meson-private/install.dat
ninja: build stopped: subcommand failed.
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_graphene/graphene/work/build-x86_64" && /opt/local/bin/ninja install
Exit code: 1
Error: Failed to destroot graphene: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_graphene/graphene/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

I've also attached the main.log file.

comment:8 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

In 535f48186988109078802144f7c3f6f04a8d99c6/macports-ports (master):

meson: Fix depfixer

Closes: #56483

comment:9 Changed 3 years ago by thetrial (alabay)

It says closed, but I still have the same problems? Although actual meson. The behaviour with graphene is exactly as shown above.

comment:10 Changed 3 years ago by prohtex

This should not be closed. It is not fixed. Same issue for me as well.

comment:11 Changed 3 years ago by prohtex

Resolution: fixed
Status: closedreopened

Not fixed

comment:12 Changed 3 years ago by geoffgrimwood

Cc: geoffgrimwood added

comment:13 Changed 3 years ago by jmroot (Joshua Root)

There are packages available for 10.7 and later, so it clearly builds in some cases. Can you attach the log from your current failure?

Changed 3 years ago by thetrial (alabay)

Attachment: graphene.log added

Graphene Log.

comment:14 Changed 3 years ago by thetrial (alabay)

It’ uploaded.

comment:15 Changed 3 years ago by kencu (Ken)

Resolution: duplicate
Status: reopenedclosed

duplicate of 56737

that ticket is newer, but has more specific info about the actual error, which involves the +universal variant of graphene.

Last edited 3 years ago by kencu (Ken) (previous) (diff)

comment:16 Changed 3 years ago by dershow

Cc: dershow added
Note: See TracTickets for help on using tickets.