Opened 3 years ago

Closed 3 years ago

#56487 closed defect (duplicate)

sane-backends @1.0.27_1 breaks on building docs

Reported by: chtonic Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.4
Keywords: Cc:
Port: sane-backends

Description

OS: Darwin Kernel Version 16.7.0: Tue Jan 30 11:27:06 PST 2018; root:xnu-3789.73.11~1/RELEASE_X86_64 x86_64

Xcode: Version 8.3.3 (8E3004b)

I was able to continue by selecting fig2dev @3.2.6a_0, but then I also needed to rebuild flow.pdf from flow.fig.

Making all in doc                      
make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_sane-backends/sane-backends/work/sane-backends-1.0.27/doc'                                  
/opt/local/bin/fig2dev -L pdf figs/flow.fig figs/flow.pdf                     
sh: -q: command not found              
Error in ghostcript command            
command was:  -q -sAutoRotatePages=None -dAutoFilterColorImages=false -dColorImageFilter=/DCTEncode -sDEVICE=pdfwrite -dPDFSETTINGS=/prepress -o 'figs/flow.pdf' -                                 
make[1]: *** [figs/flow.pdf] Error 255 
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_sane-backends/sane-backends/work/sane-backends-1.0.27/doc'                                   
make: *** [all-recursive] Error 1      
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_sane-backends/sane-backends/work/sane-backends-1.0.27'   
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_sane-backends/sane-backends/work/sane-backends-1.0.27" && /usr/bin/make -w all                      
Exit code: 2                           
Error: Failed to build sane-backends: command execution failed                
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_sane-backends/sane-backends/main.log for details.                       
Error: Follow https://guide.macports.org/#project.tickets to report a bug.    

Change History (1)

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #56474.

Note: See TracTickets for help on using tickets.