Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#56526 closed defect (fixed)

geoexpress-sdk installs dylibs with relative install_name

Reported by: news24lor Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.4.4
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: geoexpress-sdk, gdal

Description

Hi

I have a strange problem not resolved from many weeks.

I can compile GDAL with all the variants that interest me. GDAL also works well with QGIS.
The problem is when I do any update. MacPorts always founds 2 broken files and 1 broken port. The port broken is always GDAL and the computer always starts a new compilation very long and at the end I always made the same error, but my GDAL works and is up to date. I cannot clean this error. It's a loop...

Mac OS X El Capitan

MacPorts 2.4.4

GDAL 2.3.0.20180523

An help, please.

This is the log from terminal:

--->  Computing dependencies for gdal
--->  Fetching archive for gdal
--->  Attempting to fetch gdal-2.3.0.20180523_0+hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces.darwin_15.x86_64.tbz2 from http://fco.it.packages.macports.org/mirrors/macports-packages/gdal
--->  Attempting to fetch gdal-2.3.0.20180523_0+hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces.darwin_15.x86_64.tbz2 from http://lil.fr.packages.macports.org/gdal
--->  Attempting to fetch gdal-2.3.0.20180523_0+hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces.darwin_15.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/gdal
--->  Fetching distfiles for gdal
--->  Attempting to fetch gdal-fd8952b.tar.gz from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/gdal
--->  Verifying checksums for gdal                                                   
--->  Extracting gdal
--->  Applying patches to gdal
--->  Configuring gdal
--->  Building gdal
--->  Staging gdal into destroot
--->  Installing gdal @2.3.0.20180523_0+hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces
--->  Cleaning gdal
--->  Computing dependencies for gdal
--->  Deactivating gdal @2.3.0.20180522_0+hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces
--->  Cleaning gdal
--->  Activating gdal @2.3.0.20180523_0+hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces
--->  Cleaning gdal
--->  Updating database of binaries
--->  Scanning binaries for linking errors
--->  Found 2 broken files, matching files to ports      
--->  Found 1 broken port, determining rebuild order
You can always run 'port rev-upgrade' again to fix errors.
The following ports will be rebuilt: gdal @2.3.0.20180523+hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces

Change History (12)

comment:1 Changed 3 years ago by jmroot (Joshua Root)

Cc: vince@… removed
Owner: set to Veence
Port: gdal added
Status: newassigned

Please attach the output from sudo port -d rev-upgrade.

comment:2 Changed 3 years ago by Veence (Vincent)

Yes, we need more input to riddle this out.

comment:3 Changed 3 years ago by news24lor

This is the output:

--->  Scanning binaries for linking errors
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/bugpoint
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llc
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/lli
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-ar
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-as
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-bcanalyzer
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-c-test
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-cat
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-config
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-cov
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-cvtres
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-cxxdump
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-cxxfilt
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-diff
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-dis
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-dsymutil
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-dwarfdump
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-dwp
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-extract
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-link
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-lto
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-lto2
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-mc
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-mcmarkup
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-modextract
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-mt
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-nm
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-objdump
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-opt-report
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-pdbutil
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-profdata
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-readobj
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-rtdyld
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-size
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-split
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-stress
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-strings
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-symbolizer
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/llvm-xray
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/obj2yaml
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/opt
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/sancov
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/sanstats
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/verify-uselistorder
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/bin/yaml2obj
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-5.0/lib/libLTO.dylib
DEBUG: Ignoring loadcommand containing @executable_path in /opt/local/libexec/ld64/ld-latest
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/las2col
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/las2col
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/las2las
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/las2ogr
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/las2pg
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/las2pg
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/las2txt
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/lasblock
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/lasinfo
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/ts2las
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/txt2las
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/bin/txt2las
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/apptemplate/prebuilt/main-fat since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/apptemplate/prebuilt/main-fat3 since this system can't run it anyway
DEBUG: skipping ppc64 in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/apptemplate/prebuilt/main-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/apptemplate/prebuilt/main-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/apptemplate/prebuilt/secondary-fat since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/apptemplate/prebuilt/secondary-fat3 since this system can't run it anyway
DEBUG: skipping ppc64 in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/apptemplate/prebuilt/secondary-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/apptemplate/prebuilt/secondary-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/bundletemplate/prebuilt/main-fat since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/bundletemplate/prebuilt/main-fat3 since this system can't run it anyway
DEBUG: skipping ppc64 in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/bundletemplate/prebuilt/main-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/py2app/bundletemplate/prebuilt/main-universal since this system can't run it anyway
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/QGIS
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/QGIS
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/QGIS
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/QGIS
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/bin/QGIS Browser.app/Contents/MacOS/QGIS Browser
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/bin/QGIS Browser.app/Contents/MacOS/QGIS Browser
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/bin/qgis_bench.app/Contents/MacOS/qgis_bench
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/bin/qgis_help.app/Contents/MacOS/qgis_help
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/fcgi-bin/qgis_mapserv.fcgi
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/fcgi-bin/qgis_mapserv.fcgi
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/fcgi-bin/qgis_mapserv.fcgi
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/QGIS.app/Contents/MacOS/lib/qgis/crssync
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/apptemplate/prebuilt/main-fat since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/apptemplate/prebuilt/main-fat3 since this system can't run it anyway
DEBUG: skipping ppc64 in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/apptemplate/prebuilt/main-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/apptemplate/prebuilt/main-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/apptemplate/prebuilt/secondary-fat since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/apptemplate/prebuilt/secondary-fat3 since this system can't run it anyway
DEBUG: skipping ppc64 in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/apptemplate/prebuilt/secondary-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/apptemplate/prebuilt/secondary-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/bundletemplate/prebuilt/main-fat since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/bundletemplate/prebuilt/main-fat3 since this system can't run it anyway
DEBUG: skipping ppc64 in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/bundletemplate/prebuilt/main-universal since this system can't run it anyway
DEBUG: skipping ppc in /opt/local/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/py2app/bundletemplate/prebuilt/main-universal since this system can't run it anyway
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/MacVim.app/Contents/MacOS/MacVim
DEBUG: skipping ppc in /opt/local/share/cmake-3.11/Modules/CPack.OSXScriptLauncher.in since this system can't run it anyway
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/c-index-test
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/c-index-test
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-apply-replacements
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-change-namespace
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-check
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-format
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-import-test
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-include-fixer
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-offload-bundler
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-query
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-rename
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-reorder-fields
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/clang-tidy
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/find-all-symbols
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/bin/modularize
DEBUG: Ignoring loadcommand containing @rpath in /opt/local/libexec/llvm-4.0/lib/libclang.dylib
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/Qgis3.app/Contents/MacOS/Qgis3
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/Qgis3.app/Contents/MacOS/Qgis3
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/Qgis3.app/Contents/MacOS/Qgis3
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/Qgis3.app/Contents/MacOS/Qgis3
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/Qgis3.app/Contents/MacOS/Qgis3
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/Qgis3.app/Contents/MacOS/Qgis3
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/Qgis3.app/Contents/MacOS/lib/qgis/crssync
DEBUG: Ignoring loadcommand containing @executable_path in /Applications/MacPorts/Qgis3.app/Contents/MacOS/lib/qgis/crssync
Could not open libltidsdk.9.dylib: Error opening or reading file (referenced from /opt/local/bin/gnmanalyse)
libltidsdk.9.dylib seems to be referenced using a relative path. This may be a problem with its canonical library name and require the use of install_name_tool(1) to fix.
DEBUG: Marking /opt/local/bin/gnmanalyse as broken
DEBUG: Marking /opt/local/bin/gnmmanage as broken
--->  Found 2 broken files, matching files to ports
--->  Found 1 broken port, determining rebuild order
DEBUG: Broken: gdal
DEBUG: Processing port gdal @0:2.3.0.20180523_0 +hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces 
DEBUG: Processing port py36-gdal @0:2.2.3_0  
DEBUG: Processing port qgis3 @0:3.0.3_0 +postgresql10+proj5+python36 
DEBUG: Processing port py27-gdal @0:2.2.3_0  
DEBUG: Processing port qgis @0:2.18.17_2 +postgresql10 
DEBUG: Processing port py-gdal @0:2.2.3_0  
DEBUG: Processing port liblas @0:1.8.1_2  
DEBUG: Processing port postgis2 @1:2.4.4_0 +postgresql10+raster+topology 
You can always run 'port rev-upgrade' again to fix errors.
The following ports will be rebuilt: gdal @2.3.0.20180523+hdf5+jasper+mrsid+netcdf+odbc+opencl+poppler+postgresql10+proj4+xerces
Continue? [Y/n]: n

comment:4 Changed 3 years ago by news24lor

I didn't know this command but now I have deleted the two file marked as broken :

gnmanalyse
gnmmanage

and the problem has been fixed.

The two executables are from GDAL but I don't use them. I don't know why they weren't compiled.

Thanks

Last edited 3 years ago by news24lor (previous) (diff)

comment:5 Changed 3 years ago by news24lor

Now I rebuild GDAL and check in the log the point where it does not compile these two binaries of the GNM utility (Geographic Network Model)

comment:6 Changed 3 years ago by Veence (Vincent)

One of the ports you use is broken:

Can you post the output of:

port provides /opt/local/lib/libltidsdk.9.dylib

and

otool -L /opt/local/lib/libltidsdk.9.dylib

Thanks!

comment:7 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added
Port: geoexpress-sdk added
Summary: Problem with broken port - GDALgeoexpress-sdk installs dylibs with relative install_name

There might not be an /opt/local/lib/libltidsdk.9.dylib. It looks like /opt/local/share/Geo_DSDK/Raster_DSDK/lib/libltidsdk.9.dylib should be provided by the geoexpress-sdk port. You seem to already know that the geoexpress-sdk port installs libltidsdk.9.dylib (and all of its other libraries, from what I can tell) with a broken (i.e. relative instead of absolute) install_name, since in the gdal port's +mrsid variant you go to the trouble to use install_name_tool to fix all references to it in gdal—all references except those in gnmanalyse and gnmmanage.

Instead of making gdal fix these references, you should correct them at the source: in the geoexpress-sdk port. That way, anything that builds against the libraries in that port will work correctly without needing to be fixed up with install_name_tool. It looks like you are already using install_name_tool in geoexpress-sdk to fix the references to the libraries. Now you just need to additionally use install_name_tool to fix up each library's own id. I did something similar in the build phase of my oracle-instantclient port if you need an example.

Last edited 3 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:8 Changed 3 years ago by news24lor

Thanks Ryan

Yes, I know the Geoexpress-SDK library that you need to see MrSID images. I installed it and compiled GDAL with it.
The strange thing is that GDAL built in this way sees MrSID images but not all GDAL binaries are compiled (GNM utilities) just for lack of those files.

Which version of GeoSDK?
There is the 9.5.4 (last), the 9.1.0 (gcc), the 9.0.0...

Which one?

comment:9 in reply to:  8 Changed 3 years ago by ryandesign (Ryan Schmidt)

Replying to news24lor:

not all GDAL binaries are compiled (GNM utilities) just for lack of those files.

I'm not sure what you mean.

Which version of GeoSDK?
There is the 9.5.4 (last), the 9.1.0 (gcc), the 9.0.0...

At the moment, the geoexpress-sdk port is at version 9.0.0.3864. Ticket #55764 has an update to 9.5.4 which I haven't tried.

comment:10 Changed 3 years ago by Veence (Vincent)

This should be fixed now. Cf: #55764

comment:11 Changed 3 years ago by Veence (Vincent)

Resolution: fixed
Status: assignedclosed

comment:12 Changed 3 years ago by news24lor

Hi Veence

The install_name_tool command must be run on the geoexpress-sdk package before creating GDAL.

Unfortunately the update you entered I can not see it because it is only for Mac OS 10.12 and I have the 10.11.

I saw on GitHub the portfile for the new geoexpress-sdk.

MrSid 9.5.4 darwin16 is required which is for Mac OS 10.12 and later. I need it to darwin15 that is for Mac OS 10.11 and later that is there and I have downloaded (MrSID_DSDK-9.5.4.4709-darwin15.universal.clang70.tar.gz). This version is the same and works from 10.11 and later.

Those with previous OSs may use the old 9.0.0.

Please enter the darwin15 version...

Thanks

Note: See TracTickets for help on using tickets.