Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#56527 closed enhancement (fixed)

gr-lora-rpp0: Depend on wireshark2

Reported by: mf2k (Frank Schima) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: gr-lora-rpp0

Description

Currently gr-lora-rpp0 depends on the old wireshark port. Can it be changed to allow any of the Macports wireshark ports, particularly wireshark2?

Change History (5)

comment:1 Changed 3 years ago by michaelld (Michael Dickens)

probably. what's a good depends line for both versions of wireshark?

comment:2 Changed 3 years ago by mf2k (Frank Schima)

I think it depends on which library/binary it actually needs, but you could probably just base it on wireshark itself:

   path:lib/libwireshark.dylib:wireshark2
Last edited 3 years ago by mf2k (Frank Schima) (previous) (diff)

comment:3 Changed 3 years ago by michaelld (Michael Dickens)

Thx I'll try that & see.

comment:4 Changed 3 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: assignedclosed

In ff68e64831a4bcb134349ce90aa1b8889cf40907/macports-ports (master):

gr-lora-rpp0: allow using any wireshark executable

Closes: #56527

comment:5 Changed 3 years ago by michaelld (Michael Dickens)

Looks like any wireshark should work. Thx for pointing this out!

Note: See TracTickets for help on using tickets.